1

I'm using TeXmaker with MikTeX2.9 on Windows 7.

Recently I've installed revtex4-1 according to the instructions in the README file.

However when I tried to compile the sample .tex file using TeXmaker, I got the error "revtex4-1.cls", when this file was indeed present in the folder which I had included in the MiKTeX search paths.

I've tried to install TeXLive (a LaTeX editor) as suggested by someone on the web, but I couldn't get it installed for some reasons.

So what's wrong with my REVTeX installation?

closed as too broad by LaRiFaRi, zeroth, user31729, Thorsten, lockstep Jun 13 '14 at 12:44

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to TeX.SX. Please give us some code, which results in your problem. The error is just "revtex4-1.cls"? That's not very informative. TeXLive is no editor (at least I don't know it) but a TeX distribution. – LaRiFaRi Jun 13 '14 at 7:11
  • 1
    Welcome to TeX.SE! Real quick: TeXLive is not an editor, but a TeX distribution (just like MikTeX is). Various editors -- aka "front ends" can be used with either MikTeX or TeXLive. Regarding your attempt to install revtex4-1 in MikTeX: Did you use MikTeX's own Package Manager program or did you install the package "by hand"? If it's the latter, did you remember to update MikTeX's filename database by clicking on the "Update FNDB" button in the MikTeX "Settings" helper program? – Mico Jun 13 '14 at 7:14
  • 1
    Have you tried installing it via MiKTeX? Just open the MiKTeX Package Manager and search for revtex. – LaRiFaRi Jun 13 '14 at 7:15
  • 1
    Just a follow up on @LaRiFaRi's suggestion: To get revtex4-1, you'll need to install the revtex bundle via MikTeX's Package Manager utilility, and not (admittedly somewhat surprisingly) the revtex4 bundle. – Mico Jun 13 '14 at 7:22
  • Thanks everyone. The problem has been solved. In fact one did not need to do any installation when using Texmaker. When one compiles a tex file that uses revtex, it will prompt you to install the revtex package. One has to choose to install it from the internet (or a folder, rather than through a random repository). Then it shall work out fine. – user54487 Jun 13 '14 at 8:33

Browse other questions tagged or ask your own question.