3

I have recently upgraded my LyX installation form 2.0.7 to 2.1. Everything was fine until I found out that I am no longer able to open my older Beamer presentations made with LyX 2.0.6 or 2.0.7.

Whenever I try to open my older Beamer presentations in LyX 2.1 , it shows an error like this:

/tmp/lyx_tmpdir.ThevfvKK5936/Buffer_convertLyXFormatXXXXXX.lyx.YoiTshcj5936 ended unexpectedly, which means that it is probably corrupted.

I am having the same problem on both Win 7 SP1 x64 and Ubuntu 14.04 x86-64.

Initially I thought my files were corrupt. To make sure, I tried opening all of my older Beamer files. And every single time LyX showed the same error.

enter image description here

Any help would be much appreciated.

  • 1
    See here: tex.stackexchange.com/q/180664/4736 -- which is similar, but not the same. Before you invest much time and effort, why don't you go back to an older version of lyx and try to open a copy the file with the old version? Than you know whether the error is caused by a corrupted file or by the new Lyx version. If it opens there, you may think of exporting it to LaTeX and importing it into Lyx 2.1 again. – Keks Dose Jun 15 '14 at 19:52
  • 1
    This is probably a lyx2lyx issue. Many such issues have been fixed in the development versions. There will be a new release of LyX soon that you could use to convert it to the 2.1 format. Or since you're using Ubuntu it's easy to compile yourself. Note that there are many changes in Bemer for 2.1. In the long run they will be for the best but it is a bit of a rough transition. So stick with 2.0.x unless you have a reason or enjoy experimenting. – scottkosty Jun 16 '14 at 1:02
  • I installed LyX 2.0.8 on Windows and used it to open my older Beamer presentations. Exported them as LaTeX(pdflatex) and then imported them in LyX 2.1. Worked fine! Thanks @KeksDose and @scottkosty. – TDG Jun 17 '14 at 13:26
3

You've run into a lyx2lyx bug in LyX. LyX 2.1 implemented a lot of improvements for Beamer under the hood and a few on top of it (specifically with regard to options). With such a big change some bugs have been caught. Many are now fixed in the development version.

Since you're using Ubuntu it's very easy to try to development version of 2.2, which has lyx2lyx fixes for Beamer. See instructions for using the daily PPA here: http://wiki.lyx.org/LyX/LyXOnUbuntu#toc3 Note also that 2.2dev is not stable (although I personally use it and have no problems) and files you produce with it might not be read by 2.1 (unless you export to 2.1.x format). You might want to install it, see if that fixes your problem, and if so export your documents to 2.1.x format so that you can use it on your Windows as well.

If after trying the development version it doesn't work, please post a bug report and a minimal example at http://www.lyx.org/trac or send an email to lyx-devel@lists.lyx.org (also with a minimal example).

2

I have experienced the same problem using Lyx on Mac 2.1.0 version. As @scottkosty pointed out, the source of the problem is lyx2lyx. Here is my steps to use the latest version of lyx2lyx to get around this problem:

  1. git clone git://git.lyx.org/lyx
  2. cp lyx/lib/lyx2lyx/*py /Applications/LyX.app/Contents/Resources/lyx2lyx/

Now I can open the old Lyx files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.