1

I am using lyx and have to insert citation by following rules. I could not find any specific citation style in lyx.

References should be presented in the following style:

Journal Paper: Fujar, B.R., Smith, R.N., Jackson, T.R., et al. 1996. Navigating gopherspace with neural implants. J. Neurol. 10, 275–280.

Book: Hillis, D.M., and Moritz, C. 1991. Molecular Systematics. Sinaur Associates, Sunderland, MA.

Chapter within Edited Book: Knight, J.R., and Myers, E.W. 1992. Approximate regular expression pattern matching with concave gap penalties, 66-76. In Chrochemore, M., and Galil, Z., eds. Combinatorial Pattern Matching. Springer-Verlag, New York.

Citation of references in the text: References in the text should be cited by author names and publication year. When a text citation includes one or two authors, list all authors and the publication year, e.g., Smith (2008) or Smith and Jones (2008), but for text citations for three or more authors, cite the first author only followed by et al. and the publication year, e.g., Smith et al. (2008).

  • You should use biblatex and its optional maxcitenames and mincitenames. You can set style=authoryear(or one of its variants). How to use biblatex with Lyx is explained here: wiki.lyx.org/BibTeX/Biblatex. – Bernard Jun 18 '14 at 19:19
  • after installing biblatex and updating with texhash error occurred saying: biblatex missing. style option is showing the biblatex. – lyxProtein Jun 18 '14 at 19:44
  • Did you try to compile from within a "classic" tex editor, or even from the command line? – Bernard Jun 18 '14 at 19:48
  • i am using lyx 2.02 – lyxProtein Jun 18 '14 at 19:52
  • The problem is that I never used lyx and can help mainly on the tex side. Did you install biblatex from within lyx? – Bernard Jun 18 '14 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.