0

Usually when I try to create a document using the Tufte-latex classes, which table of contents could extents in more than one page, I find with the trouble of the composition of the table of contents.

I can't find the way of get a right table of contents using a symmetric layout. In this case, the second page of the table of contents look like that.

My MWE could be:

\PassOptionsToPackage{usenames,dvipsnames,table}{xcolor}
\documentclass[symmetric,marginals=raggedouter]{tufte-book}
\usepackage{etex}
\usepackage[TS1,T1]{fontenc}
\usepackage[utf8]{inputenx}
\usepackage[spanish,activeacute,mexico]{babel}
\usepackage[sc,osf]{mathpazo}
\usepackage{epigraph}
\usepackage[caption=false]{subfig}
\usepackage{graphicx,tikz,pgfplots}
\graphicspath{{./imagen/}}    
\usepackage[colorinlistoftodos,spanish,textsize=footnotesize]{todonotes}
\usepackage{hyperref}
\clubpenalty=10000
\widowpenalty=10000

\parskip0.4\baselineskip

\setcounter{tocdepth}{1}
\setcounter{secnumdepth}{1}

\author{Me}
\title{The four agreements}

\begin{document}
\frontmatter

\maketitle

\chapter{introduction}

Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

\tableofcontents

\mainmatter

\chapter{First}

Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

\chapter{Second}

Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

\end{document}

I need to create well the table of contets, in the configuration I show is impossible. I'm using TeXLive 2013 updated on Ubuntu 14.04.

Regards

  • Your MWE works fine for me but you may want to change \titlepage to \maketitle. – lhf Jun 19 '14 at 10:14
  • Hahahahaha that's right, was `\maketitle' was a mistake mine, but it doesn't fix the trouble with the table of contents. – Aradnix Jun 20 '14 at 17:07
  • Can you please explain what the problem is? I don't seem to see any misalignment in the ToC. Could you please explain in more detail where the problem is and what is the desired result? – Gonzalo Medina Jun 20 '14 at 21:37
  • Sure, the problem is the way the compilation creates an index when I try to use the option symmetric' because the first line of the second page of the index appear misaligned as in the picture I linked before. I can't find the source or the way to avoid it. When I don't use symmetric' I have not those mistakes. – Aradnix Jun 20 '14 at 21:53
  • Are there any news here? A lot of time went by since the question was posted. – Johannes_B Dec 19 '15 at 17:16
2

While I don't know how to make the ToC symmetric, I found adding a \null to the TOC just before the sectional heading that's misaligned on the second page makes it aligned again:

\addtocontents{toc}{\null}
\chapter{El Camino tolteca hacia la libertad}
1

Did you happen to enclose the \tableofcontents command inside a fullwidth environment? (Not sure if you take that into account in your MWE)? There seems to be a compatibility issue with the Tufte-book symmetric option and the fullwidth environment, but removing the fullwidth environment did it for me. It might be worth looking into other potential codes that could destablelize Tufte-book default alignments as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.