I am in the process of creating a portable LaTeX system. For this I downloaded MiKTeX 2.9 Portable, which I installed and am now trying to update. However, the 'Updateable packages' screen keeps hanging on 'Searching...' without any visible drive, CPU or network activity.

I tried solving this by changing from a random package repository to a specific one. Upon making this change, i got a dialog 'Downloading package database', which exhibits the same problem: doing nothing and not changing.

Trying to update the repository with the option 'Let me choose the repository' (choosing a different location than with the action above) results in the same problem.

Is it normal for this process to take 45 - 60 minutes? Is there something I am doing wrong, or a common problem with making these updates? I tried to find related questions, but all questions I could find are about specific error messages, not about a simply stalling update.

The only thing I can think of that might be wrong is some kind of firewall issue. However, I am trying to execute this update from a PC on which I have a regular version of MiKTeX 2.9 installed, which has no problem finding and installing packages on the fly.

Edit: I just found out that I am able to manually install packages through the package manager. So it isn't a server/network issue, the problem just arises when trying to update.

  • How long is "a really long time"? – Paul Gessler Jun 20 '14 at 20:29
  • @PaulGessler Fair point. It is 45-60 minutes, which I don't think it needs to take to check for updates frome some server. I have updated the question with the specification. – LSchoon Jun 20 '14 at 20:33
  • Is it always like this or recently happened? Some servers go down without their indexes are dying and keeps MikTeX high for no reason. – percusse Jun 20 '14 at 21:03
  • @percusse this is a recent thing, since I have only today started working on this system. I don't think it's a server issue; I can manually install packages without a problem. – LSchoon Jun 20 '14 at 21:12
  • A data point: Yesterday I downloaded the "Basic" installer for x64 and it took nearly an hour. However, during the install and subsequent update things proceeded very quickly. I suspect repository issues. – Bill Meahan Jun 20 '14 at 22:13

Unless you deliberately select "Let me choose the repository" the updater will attempt to find the "nearest" repository server based on network response time. However, if the repository server is having problems (which could be a result of system maintenance going on), its ability to find and deliver each package requested might be impaired and take far, far longer than the time its network response would indicate. Since it looks for the "nearest" repository every time it is invoked, it may very well use a different server on every invocation. Try selecting a repository manually and see what happens.

This is not a firewall problem, it is a consequence of an attempt to minimize network bandwidth by choosing the "nearest" repository.

TeX Live caches the first repository it uses and unless you deliberately change it the admin tool will use that repository every time so the results will be consistent although potentially not optimal either.

  • Your posting seems to be about TeXLive, whereas the original query was about MikTeX and slowness in its updating process. Could you make your answer address MikTeX aspects as well? – Mico Jun 21 '14 at 15:06
  • @mico I think the comment on TeXLive is only by way of contrast to the body of the answer, which deals with MikTeX. – Paul Stanley Jun 21 '14 at 15:08
  • @PaulStanley - Thanks for this clarification. – Mico Jun 21 '14 at 15:09
  • Correct @PaulStanley. The TeXLive reference was simply to contrast the way two different distributions deal with choosing a repository for an action. Neither way is "right" and neither way is "wrong" they are simply different. – Bill Meahan Jun 21 '14 at 23:20
  • Thanks for the answer. Unfortunately, I tried updating from several manually selected repositories. All with the same result: nothing :-( – LSchoon Jun 22 '14 at 12:52

I have a similar problem with the portable version on my flashdrive. From my experiences, I discovered that the update time did not depend on either the internet or the computer speed. That being said and based on what you have told us, I would say that there is probably something wrong with your program or your device.
So, if I were you, I would delete your current version of the portable LaTeX and try reinstalling it. If that does not work, I would make sure that the device you are using is not damaged.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.