I'm trying to compile the following LaTeX code:

% !TEX encoding = UTF-8 Unicode


\usepackage[english, brazil]{babel}
\usepackage{amsfonts} % for mathbb




Test. \cite{Maass}.


I get the following error:

(...lots of log stuff...)
("C:\Program Files\MikTeX\tex\latex\biblatex\biblatex.cfg")))
("C:\Program Files\MikTeX\tex\latex\biblatex\lbx\brazil.lbx"
("C:\Program Files\MikTeX\tex\latex\biblatex\lbx\brazilian.lbx"
Runaway argument?
{bibliography = {{Bibliografia}{Bibliografia}}, references = {{Refer\^\ETC.
! Paragraph ended before \DeclareBibliographyStrings was complete.
<to be read again> 


To me, it looks like biblatex is choking on the brazilian portuguese stuff, but all docs say it's fully compatible.

Which config should I change to make biblatex work with brazilian portuguese?

My environment is MiKTeX with TeXworks, my bibtex file is:

    author = "Wolfgang Maass",
        title = "Networks of Spiking Neurons: The Third Generation of Neural Network Models",
    journal = "Neural Networks",
    language = "english",
    year = 1997,
    volume = 10,
    number = 9,
    pages = "1659--1671"

EDIT: Tried with all available backends for biblatex. Same error. MiKTeX version is 2.9.4196.

  • Did you try removing backend=bibtex and running Biber, instead of BibTeX? In any case, the .bib extension should be added to the argument of \addbibresource.
    – egreg
    Commented Jun 21, 2014 at 21:35
  • 1
    Surely not MiKTeX, because none of the machines I use can run it. With TeX Live 2012, 2013 and 2014 it works flawlessly.
    – egreg
    Commented Jun 21, 2014 at 21:47
  • 1
    I guess that it is something related with the accented word Referências.
    – Sigur
    Commented Jun 21, 2014 at 23:05
  • 2
    You get this type of error if somewhere in den \DeclareBibliographyStrings-command of brazilian.lbx there is an empty line or a braces missing. I don't have any problems in a current miktex so check for updates (as admin + users) and reinstall biblatex if necessary. If the problem persist make the lbx and the log-file (not the terminal output!) available somewhere. Commented Jun 22, 2014 at 9:19
  • 4
    This question appears to be off-topic because it is about a problem caused by a corrupted TeX distribution, solved by reinstalling
    – egreg
    Commented Jun 22, 2014 at 9:48

1 Answer 1


After tinkering with package internals trying to find a missing brace (like on Ulrike Fischer's comment and some Google search results), and noticing something else was corrupted, I went for a full re-install of MiKTeX. After that, the MWE seemed to compile.

Actually, it was failing silently (a pdf was generated, but without bibliography, and the log didn't show any error). Then I noticed the biber executable was missing (it is a 64-bit MiKTeX installation, it doesn't include biber by default), and after some tinkering and creative bat file construction, installed biber and a bat file that does the job a makefile would do on Linux (I'm also using subfiles in other folders, and need some make-like functionalities).

Link to relevant stuff:

  • 1
    You will be happy to know that MikTeX now also ships a version of Biber for 64-bit MikTeX.
    – moewe
    Commented Sep 20, 2015 at 6:46

Not the answer you're looking for? Browse other questions tagged .