0

I am writing an article with an index, and I'm using the makeidx package to do so. I have made sure to include the \makeindex command in my preamble, and I have included a \printindex command near the end of my document.

On my desktop, where I am running TexMaker + TexLive, compilation of pdf-Latex results in no index being generated in the output PDF.

On my laptop, where I am running WinEdt + MikTex, everything seems to run fine. In particular, the index is generated in the appropriate location.

I'm at a loss as to how to troubleshoot this inconsistency. I've tried deleting all auxiliary files besides the source and recompiling on my desktop, but no dice.

Is there something simple I could be missing here?

5
  • You have to run makeindex. Look for it on some menu. So do pdflatex+makeindex+pdflatex+pdflatex.
    – Sigur
    Commented Jun 21, 2014 at 23:58
  • @Sigur Ah! I see, WinEdt was doing that automatically. Thank you so much! You should post that as an answer. Commented Jun 22, 2014 at 0:09
  • You are better off with imakeidx which runs makeindex automatically. Syntax is same. Just change makeidx to imakeidx.
    – user11232
    Commented Jun 22, 2014 at 0:12
  • 1
    @HarishKumar Interesting that is handy. As an aside, imakeidx seems to alter the formatting of the index. In particular, right now I only have a single column of index entries because there is a small number, and it seems to want to change it to two columns. Is there some way to override this? Commented Jun 22, 2014 at 0:25
  • 1
    Just do: \makeindex[columns=1]
    – user11232
    Commented Jun 22, 2014 at 0:27

1 Answer 1

1

You have to run the external program makeindex. Use the Tools menu or press F12.

enter image description here

Or choose it near the blue arrow and press the arrow.

enter image description here

Or you can use the Options menu and configure the Quick Build (F1) to run that sequence of commands.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .