3

I'm having some trouble with TeXLive. I was using the 2013 version but I coulnd't install Beamer. For this reason I uninstalled TeXLive 2013 and then I installed the 2014 version.

The problem is that there is no TEXMFHOME folder: I changed the default from ~/texmf to ~/.texmf but neither of them exists. How can I fix it?

edit: My operating system is Ubuntu 14.04 . I wanted to install Beamer because I selected medium installation instead of full.

4
  • 1
    mkdir $HOME/texmf in a terminal for example? Was such a folder present before the update?
    – user31729
    Jun 22, 2014 at 18:33
  • The essential information about your operating system is missing.
    – egreg
    Jun 22, 2014 at 19:20
  • You shouldn't need to install beamer unless you seclected a reduced scheme when installing TeX Live. (That is, you did not install the default full scheme.)
    – cfr
    Jun 22, 2014 at 21:16
  • @ChristianHupfer Well, the first time I installed TexLive 2013 I am quite sure it was present (and I wanted to hide that folder). Then, for other reason, I uninstalled everything and reinstalled from scratch. From that moment it wasn't present anymore.
    – Dario R
    Jun 23, 2014 at 6:45

2 Answers 2

5

Installing TeX Live never creates TEXMFHOME directories in the users' homes. Would you trust an installer program that tampers with users' personal data? I wouldn't.

If you have a GNU/Linux system, then just do

cd
mkdir ~/texmf

from a terminal window and create the necessary tree structure below it. If you are running MacTeX, then you need

mkdir ~/Library/texmf

but directly installing TeX Live on Mac OS X will need ~/texmf unless a different setting is defined in /usr/local/texlive/2014/texmf.cnf.

By the way, using TEXMFHOME for beamer is quite dubious, as it's possible to install beamer in the main tree. How to install it depends on the flavor of TeX Live you have installed. If it is the TUG vanilla TeX Live, then beamer is in collection-latexrecommended.

3
  • In /usr/local/texlive/2014/texmf.cnf I added the line TEXHOME = ~/.texmf. Anyway, do you mean that Beamer doesn't require that folder in order to be installed?
    – Dario R
    Jun 23, 2014 at 6:55
  • @dario_romagnoli Of course it doesn't need it. The line TEXHOME=~/.texmf will do nothing, as TEXHOME is not a recognized variable.
    – egreg
    Jun 23, 2014 at 7:44
  • Sorry, that's a typo. I meant TEXMFHOME In any case I installed Beamer. I think I just need to understand better how TDS works.
    – Dario R
    Jun 23, 2014 at 9:37
3

run in a terminal:

voss@shania:~/ConTeXt> kpsewhich -var-value TEXMFHOME
/home/voss/texmf

or

voss@shania:~/ConTeXt> kpsewhich -var-value TEXMFLOCAL
/usr/local/texlive/texmf-local

it shows you the current setting.

Inside the $TEXMFHOME and $TEXMFLOCAL you should have a directory structure as explained in TDS: http://www.tug.org/tetex/html/tds/tds_toc.html#SEC23

For example: A local style file should be in ~/texmf/tex/latex/myStyle/

However, why do you want to install Beamer? It is already present.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .