I'm writing my thesis. My page layout:

     \usepackage[inner=3cm,outer=2cm,tmargin=2.0cm,bmargin=2.0cm,includefoot, includehead]{geometry}

After printed, I measured the margins with ruler and margins are not good.its varies from printer to printer :s

  • 3
    Have a look at the printer setup. Often there is a scaling factor or an option to fit the paper size. – user36296 Jun 23 '14 at 10:57
  • I sometimes have the same problem, and indeed it is (when I'm sending it to a copy center) it is standard 97%. – Arne Timperman Jun 23 '14 at 12:13
  • It is common when using Adobe Reader that it shrinks page at 97%, because it apparently thinks that A4 paper doesn't fit in A4 paper. – egreg Jun 23 '14 at 13:41
  • 1
    If you are using hyperref, add the option pdfprintscaling=None. At least for Adobe’s PDF reader, this affects the initial setting for page scaling in the print dialog. – Thérèse Jun 23 '14 at 13:44
  • Another thing to check is the paper size that the printer driver is configured to assume. For example, on English Linux installations, it is often US Letter paper instead of A4 paper. – DCTLib Jun 23 '14 at 14:05

Well, first of all, don't panic!

Second, your configuration with the geometry package seems about right, so there shouldn't be any problems if that is indeed what you want your margins to be. You can see this by also setting the option showframe, e.g.:


Furthermore, you can check your layout lengths with the layouts package (see here)


%Recto Page

%Verso Page
\verb|\marginparwidth|: \printinunitsof{mm}\prntlen{\marginparwidth}


enter image description here

Third, a stated by @samcarter and @Arne, there is a tolerance related to every printer and even every sheet of paper! So don't be so hard on yourself if you see some minor discrepancies.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.