I renamed (the majority of) my PDF files to match their Bib(la)tex-keys. Yet when I have multiple entries marked and hit Alt + F, no linking is done.

It only works on an per-entry-basis and of course I'm bound to get it done all files eventually. But it is quite tiresome and costs a lot of time. Am I overlooking some option or feature here or is that not possible? Or how does any of you JabRef-users do it?

(Note for the sake of formality: JabRef is a popular tool to maintain a LaTeX bibliography. Since I'm sure the user base of JabRef is significantly large on this site I think it is warranted to ask this question here. It is worth a try, especially after it received no reply yet on its official site. I hope you'll agree.)

1 Answer 1


You can achieve this by using

Search-->Synchronize File Links.

Note that you need to specify the directory of your pdf files under

File --> Database Properties --> User-specific file directory

It somehow does not recognize the PDF directory entry.

  • 1
    I apparently didn't need to specify said directory. But I already had it properly set up under Option -> Settings -> External programs, maybe that was the (or one) catch.
    – henry
    Jun 24, 2014 at 12:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .