3

I'm trying to install the URW Garamond font (to be used with math design) on OS X 10.9 / MacTeX 2014. I downloaded and ran the getnonfreefonts script (without any error messages).

However when I try to compile the following:

\documentclass{article}
\usepackage[urw-garamond]{mathdesign}
\begin{document}
\blindtext
  A formula:
  \[
    \underbrace{\frac{\sin^{2}\vartheta}{\Theta_{lm}(\vartheta)}\left(\frac{\partial^{2}}{\partial\vartheta^{2}}+\frac{\cos\vartheta}{\sin\vartheta}\frac{\partial}{\partial\vartheta}\right)\Theta_{lm}(\vartheta)+\sin^{2}(\vartheta)(l(l+1))}_{m^{2}}=\underbrace{-\frac{1}{\Phi_{m}(\varphi)}\frac{\partial^{2}}{\partial\varphi^{2}}\Phi_{m}(\varphi)}_{m^{2}}
  \]
  and another one:
  \[
    P_l (x)\equiv\frac {1}{2^l}\sum_{k=0}^{\lfloor l/2\rfloor} (-1)^k \frac{(2l-2k)!}{k!(l-k)!(l-2k)!} x^{l-2k}
  \]
\end{document}

I still get

!pdfTeX error: /usr/texbin/pdflatex (file ugmr8a.pfb): cannot open Type 1 font 
file for reading
 ==> Fatal error occurred, no output PDF file produced!

Any help would be appreciated!

  • 1
    Did you use sudo getnonfreefonts-sys? If not, do it instead of getnonfreefonts (requires administrator privileges). – egreg Jun 25 '14 at 17:50
  • I had the same issue some days ago. Instead of doing a system install, I refreshed the map and it worked... – s__C Jun 25 '14 at 18:03
  • @s_C Please don't suggest that. It is likely to cause you grief later on in the form of problems whose causes will not be obvious. It is not recommended to use the non-sys forms of the commands for font installation. (At least, it is not recommended for unix-like systems which include OS X.) Only use the non-sys commands if you really have to e.g. because you don't have administrator rights on the machine. – cfr Jun 26 '14 at 1:02
6

Whenever possible, the -sys utilities should be used; this holds for

 fmtutil-sys

 updmap-sys

 getnonfreefonts-sys

The first utility is for recreating format files, the second one for updating the map files necessary for using Type1 fonts and not the bitmap versions, the third one is the main important for the purpose of your question.

In general fonts that are not provided directly by TeX Live should be installed system wide in the TEXMFLOCAL tree, using sudo updmap-sys for updating the map files and getnonfreefonts(-sys) is just a special case, because it provides an automatic procedure for installing some font families.

Why is it better to use the local tree and system-wide installation? Because in this way we are guaranteed that any update to the fonts in TeX Live will be reflected in the map files. If one uses updmap (or getnonfreefonts) a set of map files are created for the current user only. Since tlmgr (or TeX Live Utility on Mac OS X) only run updmap-sys, changes will not be reflected in the user's pdftex.map file or related.

So, use

sudo getnonfreefonts-sys garamond garamondx

but first check that the command line

kpsewhich pdftex.map

outputs

/usr/local/texlive/2014/texmf-var/fonts/map/pdftex/updmap/pdftex.map

If the result is different, remove the file pointed at.

0

After updating TeXLive 2018 and TeXShop this worked for me.

Rico A.R. Picone, PhD wrote in Reinstalling nonfreefonts

To get fonts like uw-garamond, run the following command or see more here.

curl --remote-name https://tug.org/fonts/getnonfreefonts/install-getnonfreefonts

sudo texlua install-getnonfreefonts

Then update the “TeX filename database” with the following. It’s worth reviewing this documentation.

sudo -H mktexlsr

sudo -H updmap-sys --force --enable Map=newfont.map

sudo texlua install-getnonfreefonts

It I kept having an error updmap [ERROR] in which it couldn’t locate newfont.map, although the file was where it said it was supposed to be! I think the above sequence works, but I could be wrong.

Updated: see picture below**Output**

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.