2

I'm trying to write a list of acronyms used in my thesis. I'm using the following code which works well...

\documentclass[12pt,a4paper]{book}
\usepackage{acronym}
\begin{document}

\chapter*{List of Acronyms} 
\addcontentsline{toc}{chapter}{List of Acronyms} 
%place for all the ackronyms
\begin{acronym}[BRGM] %as this is my longest...
\setlength{\itemsep}{-\parsep}
%define the ackronyms
\acro{BRGM}[\textit{BRGM}]{Bureau de Recherches G\'{e}ologiques et Mini\`{e}res} 
\end{acronym}

\end{document}

This works for printing them out all nice and aligned, however, when I do this the italics which I have throughout the text dissappear... I'm wondering if there's a way to keep the formatting because before adding

\begin{acronym}[BRGM] %as this is my longest...

the formatting shows the italics but not a nicely aligned list of acronyms... I'm basically asking how to align the acronyms, but keep the intended formatting of italics?

  • Welcome to TeX.SX! Please make your code compilable (if possible), or at least complete it with \documentclass{...}, the required \usepackage's, \begin{document}, and \end{document}. That may seem tedious to you, but think of the extra work it represents for TeX.SX users willing to give you a hand. Help them help you: remove that one hurdle between you and a solution to your problem. – mvkorpel Jun 25 '14 at 18:56
  • 1
    Added in the \documentclass now. Thanks. – user3590510 Jun 26 '14 at 10:10
3

I'm not sure setting the acronyms in italics is the right thing to do.

However, your problem stems from the fact that, in the list, the acronyms are by default printed in sans serif bold type and the standard sans serif font family (Computer Modern Sans) has no italic/slanted version. Indeed you get the warning

LaTeX Font Warning: Font shape `OT1/cmss/bx/it' undefined
(Font)              using `OT1/cmss/bx/n' instead on input line 13.

that tells you precisely that.

You have either to change font family or the command for printing the acronyms in the list. If you want bold face, add

\renewcommand\bflabel[1]{\textbf{#1}\hfill}

enter image description here

If you want sans serif type, add instead

\renewcommand\bflabel[1]{\textsf{#1}\hfill}

enter image description here

You get sans serif slanted without redefining \bflabel by adding

\usepackage[T1]{fontenc}

or

\usepackage{lmodern}

because the European Modern Sans and the Latin Modern fonts have the required shape

enter image description here

1

When I compiled this in TeXLive, I got this warning:

LaTeX Font Warning: Font shape `OT1/cmss/bx/it' undefined
(Font)              using `OT1/cmss/bx/n' instead on input line 14.

I inserted \usepackage{txfonts}, which made the warning go away, and the acronym was then in italics. If you got that warning, that's the problem. Your font isn't versatile enough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.