3

My bibliography compiles well, excerpt that for multiple authors with in text citations, an '&' is displayed, instead of a required 'and'. All solutions on this site I've found so far have failed. I prefer to maintain present packages; e.g. not Biblatex.

My university follows APA-style requirements. Multiple authors citations should thus display '&' only in the bibliography and in parenthetical citations; in text citations use 'and'.

For my thesis-document I use the 'Dissertate' class template as found on Github https://github.com/suchow/Dissertate.

My bibliography-style is defined as apalike2, with package natbib. NB I Use the latest version (1.6.12) of Texpad as a typesetter.

I'm rather novice to TeX but here I try to give a MWE:

\NeedsTeXFormat{LaTeX2e}
\ProvidesClass{Dissertate}[2014/01/24 v1.0 Dissertate Class]
\LoadClass[12pt, oneside, letterpaper]{book}
\RequirePackage{hyperref}

\RequirePackage{Harvard}
\renewcommand{\bibnumfmt}[1]{[#1]}
\renewcommand\bibname{References}

%!TEX TS-program = xelatex
%!TEX encoding = UTF-8 Unicode

\documentclass[School=Harvard]{Dissertate}

@article{YeoM2012,
title={Complex problem solving through Action Learning: Implications for HR development},    
journal={International Journal of Human Resources Development and Management},
volume={12},
number={4},
pages={258-273},
author={Marquardt, Michael and Yeo, Roland},
year={2012},
}
\begin{document}

\citet{YeoM2012}

\end{document}
  • If you are unwilling to switch to biblatex, you might want to take a look at the apacite package. In your "MWE", you are mixing concepts from a class file, a bibliographic database, and a .tex file; as such, it does not compile as-is. – Paul Gessler Jun 25 '14 at 23:27
  • Can you misspell "and" as {and} or \mbox{and} or a{n}d? – John Kormylo Jun 26 '14 at 4:02
  • @Paul, apacite is indeed suggested in another thread on SE but this solution won't work in my case; still '&' / 'and' are not different. I probably mix the files since I'm rather novice and most is defined in the .cls file (see Github link) that compiles with the .tex file, sorry for the inconvenience. – Lingskiwitz Jun 26 '14 at 8:01
  • @John: Not sure I understand what you mean. Do you suggest I manually define {and} in the body of the text? – Lingskiwitz Jun 26 '14 at 8:03
  • Wherever it is being converted to & (incorrectly). – John Kormylo Jun 26 '14 at 14:07
2

I'm not sure why you think apacite doesn't handle the &/and switching correctly (referring to your comment).

Here is a basic example with apacite, showing the differences between in-text citations, parenthetical citations, and the reference list itself:

Code

\documentclass{article}
\usepackage{apacite}
\usepackage{filecontents}

\begin{filecontents}{refs.bib}
@BOOK{SmJo03,
  AUTHOR         = {A. Smith and B. Jones},
  TITLE          = {Title},
  YEAR           = {2003},
}
\end{filecontents}

\begin{document}
\citeA{SmJo03} found that in-text citations of 
their work appeared with `\&' rather than `and'.

It was also discovered that parenthetical citations are 
printed with `\&' as required by the APA \cite{SmJo03}.

\bibliographystyle{apacite}
\bibliography{refs}
\end{document}

Output

enter image description here

If this doesn't work properly for you, there must be some interaction with something else on your system. The community would need a proper minimal working example (MWE) to diagnose.

  • Would it be possible to achieve the same result ("and" in the cite and "&" in the reference list) without using the apacite package? The OP posted an answer in which they say that they had to replace all \citet and \citep commands by other equivalent ones. I would like to avoid that kind of changes, if possible. I would accept an answer in which I had to 'tweak' of 'modify' a BST or DBJ file. – Vicent Jan 4 '18 at 19:11
  • @Vicent it's hard to say without seeing an MWE, which this question never had the benefit of. If you can't figure it out, I'd suggest bringing your document down to as minimal an example as possible (similar to the example in my answer) that shows the problem. Oftentimes this process will lead you to figure out the problem on your own, and if not, I'd suggest asking a new question about it. You can link to this question if it helps provide context for your own new question. – Paul Gessler Jan 4 '18 at 20:52
2

Following Paul's suggestion of using apacite package, I've come to the conclusion that natbib may cause conflicts in conjunction with apacite. I've sought and found a working solution in putting \RequirePackage[natbibapa]{apacite} in my style file (preamble) and \bibliographystyle={apacite} in my .tex file. This works perfect; the technical explanation is, amongst others, to be found on p.7 (package options) and page 15/16 of the manual from apacite package: http://texdoc.net/texmf-dist/doc/bibtex/apacite/apacite.pdf. NB for use with my GUI Texpad, I first had to manually define all natbib citation commands \citep and \citet into natbibapa commands \citeauthorp and \citeauthort, respectively. After compiling, I manually put back the original natbib commands again.

0

I wan to give my own answer to this question, just in case it helps anyone, although the OP already posted their own answer (still waiting to be accepted by themselves).

This solution does not need the apacite package to be used. However, it may need to tweak the BST file (the file containing the bibliographic style to be applied) or the DBJ file from which the BST can be obtained using custom-bib.

My 'recipe' is this:

(1) Add this piece of code just after \begin{document} or \begin{frontmatter}; or just before any piece of document where "and" is required:

%%%%%%%%%%%%%%%%%%%%%%%%%
\newcommand{\BIBand}{and}
%%%%%%%%%%%%%%%%%%%%%%%%%

If compiling this generates an error, then replace it by:

%%%%%%%%%%%%%%%%%%%%%%%%%%%
\renewcommand{\BIBand}{and}
%%%%%%%%%%%%%%%%%%%%%%%%%%%

(2) Just before the section where the reference list is meant to appear (or just before any place where "&" is required to appear), include this piece of code:

%%%%%%%%%%%%%%%%%%%%%%%%%%
\renewcommand{\BIBand}{\&}
%%%%%%%%%%%%%%%%%%%%%%%%%%

If all this doesn't have any effect on your final document, then the BST file needs to be edited. HOW? Follow these instructions:

(1) Open the BST file with a plain-text editor.

(2) Look for something like "FUNCTION {bbl.and}". Normally, something like this will appear in your BST file:

FUNCTION {bbl.and}
{ "and"}

(3) Replace that piece of code by this one:

FUNCTION {bbl.and}
{ "\protect\BIBand{}"}

(4) If the original BST was called mystyle.bst, save the edited file as mystyleBIBand.bst, for example.

(5) In your TEX document, replace \bibliographystyle{mystyle} by \bibliographystyle{mystyleBIBand}. Now try to compile the document again (you may need 'clean' it and recompile it several times). It should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.