2

Windows 7 64bit, Kile 2.9.60 with default settings and ConText mkiv. Trying to compile a test document:

\starttext
\startsection[title={Testing ConTeXt}]
This is my first ConTeXt document.
\stopsection
\stoptext

I note that I am able to compile this correctly in the DOS prompt (using context hello.tex). Kile uses these settings:

texexec --pdf --nonstopmode %source

and when I click on the ConTexT compile button it says

[ConTexT] hello.tex => hello.pdf (texexec)

[ConTexT] failed to start

I understand that this should not work, since there seems to be no texexec file on my system anywhere. So I tried changing the command to context in settings, but Kile does not allow me to remove the arguments (restores them if removed). The results with the command changed to context are the same as above. What am I doing wrong and what should I do?

1

texexec is the the older, unmaintained ConTeXt version, called ConTeXt MKII. context is the the newer, underdevelopment version of ConTeXt, called MKIV. You need to tell Kile to use context instead of texexec.

Probably call context %source from the look of it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.