3

I'm having trouble installing MacTeX 2014 after I've uninstalled 2013 on my Mac. Whenever I try to install, I get the following error clicking Install.

screenshot

I've tried to only install TeXLive-2014 and skip GhostScript and the GUI application, but that didn't help

screenshot

the same also happens if I try to only install either GhostScript or the GUI Applications.

I also tried downloading the MacTeX version from the Torrent, but I'm getting the same result. The exact version I'm trying is mactex-20140525.pkg

closed as unclear what you're asking by Paul Gaborit, user31729, user13907, Jesse, ChrisS Jan 9 '15 at 10:10

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Why did you uninstall MacTeX 2013? Not that doing so should cause problems. I'm just curious. Is there a checksum available which you can use to verify the download? Does MacTeX still include the software in the installer? Or does it now use the net install method? If the latter, is your internet connection good? – cfr Jun 27 '14 at 0:12
  • See tug.org/mactex/faq/index.html#qm01. Verify your download and check if any of the other suggestions apply. – cfr Jun 27 '14 at 0:16
1

It sounds really odd, but for some reason the MacTeX file can be corrupted through non-Safari browsers. Try downloading the file again but this time in the Safari browser.

I've run into this problem before, and just ran into it again now. However, this fix has now worked for me twice on two different computers and at two different times.

  • 2
    This is a rather a comment than an answer. – user31729 Oct 11 '14 at 6:27
  • @ChristianHupfer, what do you mean? I think this is the solution to the problem... – David Diez Oct 14 '14 at 6:01
  • @DavidDiez Here, many people have used Chrome or Firefox to download and install MacTeX without any problems... – Paul Gaborit Jan 9 '15 at 8:34
  • 1
    @PaulGaborit I've found the zip file corruption to be a sporadic problem... it's seemed to fix it twice for me when I have had issues in 2010 (IIRC) and 2014. This solution had been reported in another forum when I had run into this issue the first time around. I don't have an explanation about why this fix would work, and yeah, I was skeptical as hell the first time I tried it. I'm still not 100% sure it is a true fix. But rather than not suggest what has worked for me, I figured I'd toss out a possible solution for those encountering the exact same problem. – David Diez Jan 14 '15 at 5:33
  • 1
    I hit this error using a copy of Mactex 2016 I downloaded with Chrome 58. Redownloading with Safari solved the problem. – rensa May 9 '17 at 4:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.