4

I am using a two-column format for my paper. In the bottom left column I have the following:

Beginning introduction text. Next sentence with links to the terms
Skype\footnote{http://www.skype.com}, Google+Hangouts\footnote{link here}
and Facetime\footnote{link here} some text here. Proceeding introduction text..

Somehow this part of the text immediately goes to the upper right column of the paper but I just want it to stay in the down left and proceed in the upper right corner. If i delete the \footnote commands it looks good but I do however want the numbering and footnotes to work properly.

enter image description here

As shown the Introduction shifts downwards to compensate for the 3 footnotes in the upper right column. However, If I delete the footnotes the Introduction section aligns under the abstract perfect.

4
  • 2
    Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – mvkorpel
    Jun 26, 2014 at 22:39
  • There might be a way to avoid this, but the exact text would be very helpful (as TeX's page-breaking algorithm is based on the text you give it). Please provide an MWE as mvkorpel suggests. Jun 26, 2014 at 23:02
  • 1
    From what can be seen, you're just unlucky: the first line in the second column can't be moved at the bottom of the first column, because there wouldn't be space enough for two footnotes. Possibly \enlargethispage{\baselineskip} just before the \section{Introduction} command can solve the problem. I'd first try rewording, though. You might also look at the ftnright package that makes all footnotes go at the bottom of the right column, independently of the marker's location.
    – egreg
    Jun 26, 2014 at 23:12
  • Yes, the \enlargethispage{\baselineskip} worked. Awesome, thanks :)
    – Dan
    Jun 27, 2014 at 7:57

1 Answer 1

4

The normal setting when in two column format is to place footnotes at the bottom of the same column where the footnote mark is.

You're being very unlucky, because the line that goes at the top of the right column has two footnote markers. It would probably fit, together with the footnote, if it had only one, but, apparently, there is no room for the third line corresponding to the second footnote.

First of all, don't worry about these problems until the text is essentially in its final form, in particular when you know that the abstract is finished.

The best method for solving such problems is rewording. A different choice of words or a change in their order can avoid the unfortunate situation. For instance, you might try shortening the abstract by one line.

The shortening of the abstract might also be achieved by adding

\looseness=-1

just after the ending period, since this command tell TeX to try harder into making the paragraph one line shorter than the “ideal” length.

If none of these attempts succeeds, you can try adding a line to the page length, but beware that this might be rejected by the journal/proceedings editors in case of a submission: place

\enlargethispage{\baselineskip}

anywhere in the first page; a sensible location would be above \section{Introduction}.

A different approach would be

\usepackage{ftnright}

that deals with footnotes in two column format in a different way: all footnotes go at the bottom of the right column, independently of where the mark falls. However, this format might be rejected in case of a submission.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.