When using Forest package to chart an organizational structure, I have to limit it to 4-5 hierarchy levels, as both pdflatex or lualatex throw an error ! TeX capacity exceeded, sorry [save size=50000].

The forest that fails contains approximately 500-600 nodes. There is only one forest per file.

I already tried to increase MikTex 2.9 (updated to the current) main memory by running

initexmf --edit-config-file=pdflatex
initexmf --dump=pdflatex 

but the error is still there and the number 50,000 in the error message is still the same. Is there a similar INI file for lualatex?

Q: Are there any other methods that would allow to increase memory utilization allowed for pdflatex or lualatex? When they run, they do not exceed 43 MB and 75 MB respectively before they exit with the error.

I am not providing an MWE yet as 1) I would have to scramble data and it would become hard to read, and 2) it is unlikely anyone here is prepared to spend time sifting thru 500 nodes anyhow. Open to suggestions!

One of the answers here suggested a workaround of including

\tikzset{external/system call= {pdflatex -save-size=800000 
                               -jobname "\image" "\texsource"}} 

but the error is still there.

Also tried to use command line option --extra-mem-top=2000000 with no success.

  • 2
    luatex should use dynamic memory allocation and not use those settings, as far as I understand, do you get the same error with luatex? – David Carlisle Jun 27 '14 at 15:43
  • Yes, pdflatex or lualatex give the same error: ! TeX capacity exceeded, sorry [save size=50000]. – ajeh Jun 27 '14 at 15:56
  • Is this the same question as tex.stackexchange.com/q/185153/39222? (Linked to tex.stackexchange.com/q/134597/39222.) – cfr Jun 27 '14 at 21:06
  • @cfr No, this question is different, as the linked applied to TexLive, but this applies to MikTex. However, I am now facing a ridiculous situation, where after minor changes (that mostly have to do with increased number of lines drawn between the Forest nodes) lualatex started throwing error messages on the smaller forests, but pdflatex compiles them fine! – ajeh Jul 11 '14 at 16:06
  • I have the same problem. Have you found a solution? – sinned Jan 22 '15 at 16:16