4

I have a problem with ipe. I recently reinstalled my system with Ubuntu 14.04. I installed texlive 2013 manually and ipe 7.1.4 by the package from the software center.

When I start ipe using ipe. I get the following error:

An error occurred during the Pdflatex run 
Error writing Latex source

When I start ipe using sudo ipe. I get the following error:

An error occurred during the Pdflatex run
There was an error trying to run Pdflatex

I first thought that I did not correctly configured the environment variable for the LaTeX directory for ipe IPELATEXDIR. However when I checked the environment variable it really points to:

which pdflatex
/usr/local/texlive/2013/bin/x86_64-linux//pdflatex
echo $IPELATEXDIR
/usr/local/texlive/2013/bin/x86_64-linux/
echo $PATH
/usr/local/texlive/2013/bin/x86_64-linux/:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/home/wg/.local/bin

I then thought it is because ipe tries to run Pdflatex instead of pdflatex. So I created a symoblic link in /usr/local/texlive/2013/bin/x86_64-linux/ for Pdflatex. This did not work either, still the same error messages. I also looked for a log file inside ~/.ipe/ but there I can only find a temporary .tex file.

When I run sudo ipe -show-configuration I obtain:

Ipe 7.1.4
Lua code: /usr/share/ipe/7.1.4/lua/?.lua
Style directories: /home/wg/.ipe/styles, /usr/share/ipe/7.1.4/styles
Styles for new documents: basic
Autosave file: /home/wg/%s.autosave
Documentation: /usr/share/ipe/7.1.4/doc
Ipelets: /home/wg/.ipe/ipelets, /usr/lib/ipe/7.1.4/ipelets
Latex directory: /home/wg/.ipe/latexrun/
Fontmap: /usr/share/ipe/7.1.4/fontmap.xml
Icons: /usr/share/ipe/7.1.4/icons/

Anyone has any ideas?

-edit-

I noticted that ipe shows in the console kpathsea: Running mktexfmt pdflatex.fmt when it tries to run LaTeX.

4

Apparently I totally misunderstood the environment variable IPELATEXDIR. I always thought it had to be set to the location to which pdflatex points. But the environment variable indicates the location where temporary latex files are stored. By default it is. ~/.ipe/latexrun. After I changed it back I still got the same error. This was caused due to the fact that the ipetemp.tex file was protected due to the fact that I always used sudo ipe to start ipe. This caused a error when ipe wanted to execute pdflatex ipetemp.tex. After fixing the access rights everything worked back as normal.

  • I'm sorry if in the related thread I set the value of IPELATEXDIR to point to the binaries directory, but I know nothing about Ipe and just used the value you proposed. Maybe it's better to fix also that thread with better values. – egreg Jun 29 '14 at 13:34
  • No worries :-), and I was indeed planning on fixing that. – WG- Jun 30 '14 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.