I got a bad problem with the width of my table. I can't get the point why its so wide.

I'm using latexmk.

Here's my code:


% my imports
\usepackage[ngerman, num]{isodate}

% import from used template

% define paper geometry
\geometry{a4paper, left=20mm, top=27mm, right=20mm, bottom=27mm, headsep=10mm,bindingoffset=10mm}



% titlepage toc tof and so on...
    Event & Description \\
    \texttt{SomeOfMyEvents} & Description of the events goes here...
    large large texts should be here line 1
    large large texts should be here line 2
    large large texts should be here line 3
    large large texts should be here line 4
    large large texts should be here line 5
    large large texts should be here line 6
    large large texts should be here line 7
    large large texts should be here line 8
    large large texts should be here line 9
    large large texts should be here line 10
    large large texts should be here \\
% ...

and my result looks like this: enter image description here

The rule wit the romic II is my textwidth. How you can see this table is much wider than textwidh. If I try to set the width to 0.5\textwidth only the hline's of the table will be as half as long, the columns stay the same.

I even tried wit package tabulary, tabu, and tabular* with p{4cm}p{4cm} didn't work either. I'm running out of ideas. I hope some one has a better idea on this purpose.


I added more real code. Now only the name of the events and the content of my description varies.

EDIT #2:

Due to comments i added the complete preamble of my document. The picture i show is the output of my code shown above.

  • this table ist just an example. What I really needing is lX because the X should held long lines of text. But it is generating the table wrong too. According to the documentation of tabularx|y the table should have the width of my text and the X should be automatically set. Specifying two XX doesn't work properly either.
    – Marschal
    Jun 28, 2014 at 15:41
  • I edited my code to provide a more realistic example. However this has no impact on my table.
    – Marschal
    Jun 28, 2014 at 15:56
  • 2
    Clearly the code you posted does not produce the image you show of the problem. Please edit the question so your code is a complete example from \documentclass to \end{document} and show the image of the output from that code Jun 28, 2014 at 16:03
  • The new example generates an error ! LaTeX Error: \l@subfigure undefined. Once latex generates an error you should not be surprised about any typeset result, tex's recovery actions try to let it continue they do not try to make a sensible typeset result Jun 28, 2014 at 16:16
  • Your right, i don't using subfigure. That was a peace from a template I used. Anyway this has no impact on my result. I edited my code above.
    – Marschal
    Jun 28, 2014 at 16:20

1 Answer 1


Thanks for posting a full MWE. The culprit turns out to be the pdfsync package. I can't tell which of the many other packages you also load it interacts with badly, but the upshot of its presence is the terrible look of the table.

The user guide of the pdfsync package suggests that

in case of severe conflicts with another package, try instead


Sure enough, adding the novbox option solves the immediate problem.

I honestly don't know enough about the pdfsync package to tell you if there's a better solution. Quoting from the "Bugs" section of the package's user guide:

pdfsync uses extremely [sensitive] code. You should not use pdfsync on final documents because it can change the layout rather significantly (different page/line breaks are the most obvious changes).

This isn't the most confidence-inspiring statement, is it?

  • Oh thanks a lot! That's the snag! This solved my problem.
    – Marschal
    Jun 28, 2014 at 16:24
  • I'm using pdfsync during the creation of my documents because it simply easier in combination of Vim. However i'll comment out pdfsync in my final version!
    – Marschal
    Jun 28, 2014 at 16:34
  • 2
    As noted in the pdfsync docs, this functionality has been built-in to pdflatex for some time. It's called synctex, and you might find this question helpful in setting it up with vim: tex.stackexchange.com/questions/2941/… Jun 29, 2014 at 0:23
  • 2
    It's simple: pdfsync should never be used. Activate pdfsync=1 in the command line and all will go smooth, with synchronization between input and output.
    – egreg
    Jun 8, 2015 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.