2

been writing up my thesis and everything works pretty well except for the citations and the bibliography.

I am using a Tex file that is split up into different parts which I include using the \input {something.tex} command. Everything compiles just fine, except when I try to compile the document again using Bibtex I get the following output:

This is BibTeX, Version 0.99d (TeX Live 2013)
The top-level auxiliary file: BA.aux
A level-1 auxiliary file: 00-Titel_etc/Titelblatt.aux
A level-1 auxiliary file: 00-Titel_etc/eidesstattliche_Erklaerung.aux
I found no \citation commands---while reading file BA.aux
I found no \bibdata command---while reading file BA.aux
I found no \bibstyle command---while reading file BA.aux
(There were 3 error messages)

I call the citations in the subfiles using for example: \cite {Scott.2011} with the corresponding line in the .bib file: @article{Scott.2011, …}

I call the bibliography using the following:

\defbibheading{Literaturverzeichnis}{\section{Literaturverzeichnis}}
\bibliographystyle {plain}
\bibliography {Quellen} 
\nocite {*} 
\printbibliography[heading=Literaturverzeichnis]

And my bibliography file is in the same folder as the overall Tex file (namely BA.tex). But even with the \nocite {*} command all I get on the bibliography page is the output "Quellen" which is the name of my .bib file.

Don't actually know what I am doing wrong… been googling all over the internet, found similar problems, but none of the solutions brought any help or even change. I am using Texshop on a Mac by the way.

Appreciate any kind of help or hint as to what to try or do!!!! Thanks a lot in advance!

closed as unclear what you're asking by moewe, user31729, Guido, ChrisS, Torbjørn T. Jul 6 '14 at 8:20

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    You are using biblatex by the look of things: do you have backend=bibtex in the options when loading it? If not, it will default to Biber, which uses a different mechanism to pass data. – Joseph Wright Jun 28 '14 at 16:31
  • 1
    Scott.2001 or Scott.2011? – Sigur Jun 28 '14 at 16:32
  • @Sigur 2011 of course… has been edited. thx. – budekatude Jun 28 '14 at 16:46
  • 4
    @budekatude Nothing to do with your editor. Somewhere in your preamble you have a line \usepackage{biblatex} or similar, which needs to have the option if you are using BibTeX, e.g. \usepackage[backend=bibtex]{biblatex}. – Joseph Wright Jun 28 '14 at 16:50
  • 3
    You are mixing biblatex (\printbibliography) and non-biblatex-code (\bibliographystyle) that's not a good idea. And if you want to use biblatex you should better change your editor so that is uses biber instead of adding backend=bibtex. See e.g. texwelt.de/wissen/fragen/1909/… – Ulrike Fischer Jun 28 '14 at 16:54