I am new to latex and am trying to get my first document working. In my document I have an itemized list and in some of the items I have the word file. When I compile it to a pdf document using pdflatex version 2.9.2 from MiKTeX 2.9.2 updated to latest packages last night,, the "fi" from the word file or profile does not show up when I view the pdf

A sample document with this problem:

\title{Just a test document}
\item Use a file containing 100 lines of text.
\item Read the file and compute the md5 checksum.
\item This is my profile.

Any suggestions would be appreciated.

  • "does not show up" on paper or using a PDF viewer? – Thruston Jun 28 '14 at 20:45
  • 5
    Welcome to TeX.SX! You probably have the same problem as in LaTeX does not print words correctly: inputenc/fontenc problem – egreg Jun 28 '14 at 20:46
  • 2
    The code compiles as normally here. I can't reproduce your issue. :-( – 1010011010 Jun 28 '14 at 20:46
  • 2
    To expand a little on @egreg's comment, fi is converted to a ligature in many fonts. Sounds like something's wrong with the font that would contain that ligature. – Tom Zych Jun 28 '14 at 22:45
  • I tried the workarounds specified in the link given by @egreg, but they didn't help. – user56278 Jun 29 '14 at 0:59

Your example probably doesn't say the truth about your document. I guess (as egreg in his comment) that in your document you don't have the two chars f + i but the fi glyph and this would disappear as you are using the default font encoding OT1, and this encoding doesn't have glyphs on every position.

Copy this here in an utf8-encoded file and compile:

%\usepackage[T1]{fontenc}     %step 1
%\usepackage[utf8]{inputenc}  %step 2
%\usepackage{newunicodechar}  %step 4
%\newunicodechar{fi}{fi}       %step 4




% fi=fi                         %step 3 

the 228-Symbol and the ä will not be there:

enter image description here

step 1: Now uncomment the fontenc-line: the symbol will apppear, but the ä won't be printed correctly.

enter image description here

step 2: Uncomment the inputenc line and now the ä will be okay.

step 3: Uncomment the fi line: You will get an error, as latex doesn't know this input glyph.

step 4: Uncomment the last two line in the preamble: now the fi works too.

enter image description here

  • Great this worked fine. I actually just had to uncomment the first line to get my file to compile properly, but I left the other lines in place to have for documentation purposes. – user56278 Jun 29 '14 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.