2

I create a slide using the beamer template in LyX using the following steps:

  1. Set environment to Frame
  2. Edit the Frame title to "Test"
  3. Press the right arrow and enter, change environment to itemize

Lyx automatically inserts \end{frame} after the \begin{frame}{test} without inserting my itemize environment in between. If instead I simply type a bunch of text instead of an itemize environment then things are fine.

I am using LyX 2.1. This did not happen in previous versions of LyX.

I do not include MWE as I would like somebody to repeat my steps to see if they are seeing the same issue.

  • I believe this is by design. Take a look at the Beamer manual (Help > Specific Manuals > Beamer Presentations). It's extremely informative. – scottkosty Jun 30 '14 at 1:53
3

I see the same, but hit the Tab key after starting the itemize, and it is moved within the frame. Alt + Shift + or Edit --> Increase list depth does the same.

The manual (Help --> Specific manuals --> Beamer presentations) does mention this, although without specific mention of lists:

enter image description here

  • yes i have noticed this as well. this might be a bug or simply how the 2.1 version of LyX works, i cannot tell... – Alex Jun 29 '14 at 21:17
  • 1
    @Alex If you suspect a bug, ask in the LyX mailing list, or simply add an issue in the bug tracker. – Torbjørn T. Jun 29 '14 at 21:19
  • good idea - i'll mark you answer as correct – Alex Jun 29 '14 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.