Okay I know there have been posted very similar questions like these. However their solutions do not seem to work in my case.

I tried to install Mathtime Pro 2. I have texlive 2013 and Ubuntu 14.04. I first did found this topic: Help using MathTime Pro 2 fonts in Ubuntu Linux with tex-live after which it refers to Problems installing MathTime Professional 2 font on TexLive.

I tried their solutions but I still keep getting the error

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 4+0/600 --dpi 2400 mt2exf
mktexpk: don't know how to create bitmap font for mt2exf.
kpathsea: Appending font creation commands to missfont.log.
!pdfTeX error: pdflatex (file mt2exf): Font mt2exf at 2400 not found
 ==> Fatal error occurred, no output PDF file produced! 

The log file from the installer provided by Problems installing MathTime Professional 2 font on TexLive can be found here: http://pastebin.com/Gk9AHuFP

I also tried with the lite version but that does not seem to work either.

I have to note that I recently also installed MinionPro font. During the install of that font I also stumbled onto problems.

I hope someone can help me with this problem.


So I removed all my texlive installations and all files and folders. I downloaded the new texlive version, 2014, and installed it using the installer. I installed it with the following settings:

enter image description here

Now where do I need to put (merge) the texmf folder of mtpro2? /usr/local/texlive/texmf-local or /usr/local/share/texmf or ~/.texmf?

Afterwhich I need to run

sudo texhash
sudo updmap-sys --disable mt-belleek.map --nomkmap
sudo updmap-sys --disable belleek.map --nomkmap
sudo updmap-sys --disable mt-yy.map --nomkmap
sudo updmap-sys --disable mt-plus.map --nomkmap
sudo updmap-sys --enable Map mtpro2.map

and maybe vim $(kpsewhich updmap.cfg), add Map mtpro2.map and run sudo updmap-sys. Correct?

  • This clearly seems a problem with the .map file. Did you run updmap-sys? Did you add the relevant entry in the updmap.cfg file? The message The following map file(s) couldn't be found: mtpro2.map (in /etc/texmf/web2c/updmap.cfg) seems clear about the problem.
    – egreg
    Commented Jun 30, 2014 at 18:05
  • In other words, did you do updmap-sys --enable Map mtpro2.map?
    – egreg
    Commented Jun 30, 2014 at 18:08
  • Yes I did. I also checked sudo vim $(kpsewhich updmap.cfg). And it does contain Map mtpro2.map. I should note however that my updmap.cfg is located at /usr/local/texlive/2013/texmf-config/web2c/updmap.cfg when I run kpsewhich updmap.cfg Not at /etc/texmf/web2c/updmap.cfg. Both .cfg-files do however contain Map mtpro2.map.
    – WG-
    Commented Jun 30, 2014 at 18:15
  • Do you have multiple installations of TeX Live? The output from kpsewhich suggests that you are using TL installed using upstream's installer while the presence of the file in /etc and the information in your question suggests that you are using TL from Ubuntu. It is not a good idea to have multiple installations from different distributions. (It is fine to have e.g. TL 2013 and TL 2014 from upstream but mixing TL from upstream with TL from Ubuntu will almost certainly cause problems.) When you ran updmap-sys which file did it use? What was the output? What is your user's PATH?
    – cfr
    Commented Jun 30, 2014 at 20:42
  • 2
    Everything extra should be installed under /usr/local/texlive/texmf-local and mktexlsr should be run. Append Map mtpro2.map to the file /usr/local/texlive/texmf-local/web2c/updmap.cfg (create it, if it doesn't exist) and run updmap-sys. All of this with administrator privileges.
    – egreg
    Commented Jul 1, 2014 at 19:35

1 Answer 1


In this answer I assume a standard TeX Live is used, not one packaged by Debian, Fedora or similar distributions.

Extra material should be installed either in TEXMFLOCAL or TEXMFHOME. The first location is


while TEXMFHOME refers to ~/texmf (~/Library/texmf with MacTeX).

Fonts should always be installed in TEXMFLOCAL for several reasons (see the related question URW Garamond installation on OS X).

This of course requires administrator privileges.

  • Install the material by expanding the archive at the top level of /usr/local/texlive/texmf-local or by moving manually the files.

  • Run mktexlsr.

  • Open the file


    (creating it if necessary) and append the line

    Map mtpro2.map
  • Run updmap-sys

This should make the fonts available to all users of the system.

Note. Although

updmap-sys --enable-map mtpro2.map

(with administrator privileges) instead of the last two steps above appears to work in the same way, there is a big advantage in doing as explained above: when TeX Live 2015 will be issued and installed, the file /usr/local/texlive/texmf-local/web2c/updmap.cfg will remain exactly the same and the run of updmap-sys made by the installation procedure will make the MathTime Pro fonts available in the new release without having to remember activating them manually.

  • thank you for this answer. I was planning on typing this myself, but you already did :-). I think this is also a very clear text when you want to install any font.
    – WG-
    Commented Jul 1, 2014 at 22:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .