2

I use Kile's live preview feature as suggested in this question. In the new Kile (the about box says I'm using 2.9.60), also forward search is working. My problem is that the location where Okular shows the forward search position (indicated by a thin blue line) is vertically centered in Okular's window. Is there a way to change the position, so that the forward search match is shown more to the top of Okular's window?

This is my MWE:

\documentclass[10pt]{beamer}
\begin{document}
\begin{frame}
This is a test frame
\end{frame}

\begin{frame}
\frametitle{Test frame with columns}
\framesubtitle{Columns lead to forward search match in the title}
\begin{columns}

\begin{column}{0.5\textwidth}
This is the first column...
\end{column}

\begin{column}{0.5\textwidth}
...and this is the second column
\end{column}

\end{columns}
\end{frame}

\begin{frame}
Another test frame
\end{frame}

\end{document}

The problem is that the forward search has trouble with the columns and only "finds" the title of the frame. Since the forward search match is centered vertically, the frame is so far down that it is cut off at the bottom:

using Okular with forward search

I would like to have the blue line with the forward search match to be near the top of Okular's window, maybe at 25% or so. Is that somehow possible?

  • When Okular is not embedded, it has an option to display the pdf continuously or page by page. You should look for such an option, very useful when you are working on slides. I don't know if it is possible in the version embedded in kile, though. – Clément Jul 3 '14 at 12:33
  • Thanks for the tip! It is possible via View > Document Viewer > Continuous. So that's a nice workaround. – Edgar Jul 3 '14 at 13:00
  • And I honestly think that what you were aiming at is not possible, or at least very hard. – Clément Jul 4 '14 at 7:05
  • You're probably right. Do you want to write this up in an answer so that I can accept it? Although it would be nice to configure the location, showing only a single page is good enough since nothing is missing. – Edgar Jul 4 '14 at 9:13
1

As suggested by Edgar, I transform my comment into an answer.

A workaround is to change the way your pdf is displayed by Okular: just go to View > Document Viewer > Continuous so that the frames are displayed one by one.

It is, I think, more convenient to always work that way with slides.

To answer more specifically your question, I think you should contact the Kile Team.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.