1

I tried to compile the following document:

\documentclass[a4paper,12pt]{article}
\begin{document}
Hello World!
\end{document}

When I compiled it, pdflatex said:

pdflatex demo.tex 
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Debian)
 restricted \write18 enabled.
entering extended mode
(./demo.tex
LaTeX2e <2011/06/27>
Babel <3.9h> and hyphenation patterns for 26 languages loaded.
(/usr/share/texlive/texmf-dist/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/usr/share/texlive/texmf-dist/tex/latex/base/size12.clo))
No file demo.aux.
[1{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}] (./demo.aux) )</usr/shar
e/texlive/texmf-dist/fonts/type1/public/amsfonts/cm/cmr12.pfb>
Output written on demo.pdf (1 page, 9898 bytes).
Transcript written on demo.log.

So I guess the problem is that there is no aux-file? When I tried to validate the document in http://www.pdf-tools.com/pdf/validate-pdfa-online.aspx with PDF/A-3b, it gave the following mistakes:

Validating file "demo.pdf" for conformance level pdfa-3b
The separator after an 'obj' must be an EOL. (2)
The separator before an 'endobj' must be an EOL.
The key Metadata is required but missing.
A device-specific color space (DeviceGray) without an appropriate output intent is used.
The document does not conform to the requested standard.
The file format (header, trailer, objects, xref, streams) is corrupted.
The document contains device-specific color spaces.
The document's meta data is either missing or inconsistent or corrupt.
Done.

So how can I fix those issues?

0

There is no problem here, the file demo.aux is created first for any links to be inserted on the re-run (if needed) and you can run it a second time for it to input it. You can still view the PDF file the first time as the output says that output has been written to demo.pdf

Output written on demo.pdf (1 page, 9898 bytes).
4
  • Yes, but validator gave me 8 mistakes so how can I for example make sure whether document's meta data is missing? – novice Jul 4 '14 at 9:44
  • All the PDF files I've opened through the command line with a PDF viewer have always complained about some object or other in the PDF file, but they always display correctly. TeX and LaTeX are know for being notoriously stable. Have you tried opening the file with a viewer? – user133987 Jul 4 '14 at 9:48
  • I tried to open and I can see it well. So it is not worth to use that validator? – novice Jul 4 '14 at 9:50
  • Not in this case, if there was a problem, pdfTeX would have notified you about it there and then. The only time I would ever think about using a PDF file validator would be when testing and developing the pdfTeX engine, as that's what outputs the PDF data. – user133987 Jul 4 '14 at 9:52
0

PDF/A is a standard for the archival of documents. However, pdflatex does not guarantee to create documents that conform to this standard by default.

How to compile files that conform to the PDF/A standard has been addressed in other posts. See, e.g.: How to generate PDF/A and PDF/X? for details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.