11

I'm writing my second document in latex and I'm using my universities template. But since I'm working on an English document and the template is for German papers I have to adjust the language.

...
\begin{document}
\selectlanguage{english}

but it fails with:

! Package babel Error: Unknown language `english'. Either you have
(babel) misspelled its name, it has not been installed,
(babel) or you requested it in a previous run. Fix its name,
(babel) install it or just rerun the file, respectively.

I tried to: sudo apt-get install texlive-lang-english and even: sudo apt-get install texlive-lang-all

Any idea how to fix this?

  • have you passed english as option to the babel package? \usepackage[english,<other languages>]{babel}`... – clemens Jul 4 '14 at 15:23
  • I use \usepackage[ngerman]{babel} because \usepackage[english,ngerman]{babel} gives me numerous errors, which from what I've googled are caused because prior commands already issued the usage of english babel.. – apoc Jul 7 '14 at 8:59
  • luckily sudo apt-get install texlive-lang-all already fixed my problem :) – BoJack Horseman May 26 '15 at 12:24
  • I found an error like this when using revtex and have bibliographic entry (bibtex) with the field language =. Solved it by removing the language field. Very strange. – alfC Dec 9 '17 at 5:30
14
\usepackage[english,ngerman]{babel}

Then ngerman is active at the begin of the document and you can switch to english. If you cannot change the package, then write before \documentclass:

\PassOptionsToPackage{english}{babel}
\documentclass{whatever}
...
  • perfect.. I don't really understand what solved or caused my problem but it's fine now! I used \usepackage[ngerman]{babel} and before the documentclass \PassOptionsToPackage{english}{babel} as well as after \begin{document} \selectlanguage{english}! thank you! – apoc Jul 7 '14 at 9:02
  • 2
    In this case a \usepackage[ngerman,english]{babel} would be okay if english is the main language. The last defined language in the list is the active one after \begin{document} – user2478 Jul 7 '14 at 9:53
2

You have to use:

\selectlanguage{English}

With a 'E' it should work.

Work with polyglossia and should with babel too.

0

For me the issue was solved when i removed the following line from all items in my BiBTeX file:

language = {English},

I generated the BiBTeX file with Zotero, which automatically generates this line.

Edit: Explanation I came to this thread having the same error message as the user apoc. But the answers did not fix my problem. I therefore assume that another problem causes the same error message (seems to be an internal bug). So if people cannot fix the problems with the answer above they can still try my solution. Believe me, I am a puzzled as you that such a bug exists.

  • Can you please explain why that should solve the given issue? Following the comments under the question language english was simple not installed ... – Mensch Jul 30 at 13:43
  • I think this is a different problem than in the question. OP did not mention BibTeX. I would however have expected the accepted answer to solve your problem, too. Maybe you should ask a new question (don't forget an MWE) so we can sort that out. Removing the information from the bib file seems like a rather suboptimal solution. – schtandard Jul 31 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.