5

I am trying to compile a simple tex file but I get this warning and no bibliography printed out:

Package biblatex Warning: No "backend" specified, using Biber backend.

I am using Kile on Ubuntu 14.04. While the same exact file on another pc with Ubuntu 12.04 is correclty working. What is the problem? How can I solve it?

Here is my MWE:

\documentclass[a4paper,11pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[italian,english]{babel}
\usepackage[T1]{fontenc}
\usepackage{booktabs}
\usepackage[font={small}, labelfont=bf, hypcap=true]{caption}[2004/07/16]
\usepackage[unicode,colorlinks=true]{hyperref} 
\usepackage[babel]{csquotes}
\usepackage[style=authoryear-comp,maxcitenames=1,maxbibnames=99,sortcites=true,firstinits=true,doi=false,url=false,isbn=false, hyperref]{biblatex}%style=numeric-comp,sorting=none,backend=biber

\renewbibmacro{in:}{% elimina il in nella biblio
  \ifentrytype{article}{}{%
  \printtext{\bibstring{in}\intitlepunct}}} 

\renewcommand*{\bibfont}{\small}

\bibliography{biblioTC}

\title{My paper title}
\author{Me} 
\date{}

\begin{document}

\maketitle

\newpage

\section{Test}

Lalalalalalalalalala \cite{Colitti2014}.

\newpage
\phantomsection\addcontentsline{toc}{section}{\refname}      


\printbibliography

\end{document}
  • 3
    With biblatex, ou shouldn't write \bibliography{biblioTC}, but addbibresource{biblioTC.bib}. That said, did you run the chain: (pdf)latex > biber > (pdf)latex > (pdf)latex? – Bernard Jul 6 '14 at 13:55
  • With Kile on the other pc works also with \bibliography. Anyway I tried with \addbibresource and I get that the .bbl file is in the wrong format - expected 2.3. I guess the problem is in the compiler or in the settings or installation of bibtex. – Stefano_g Jul 6 '14 at 14:22
  • Following up on Bernards comment, have you processed as in tex.stackexchange.com/q/63852/15925 ? – Andrew Swann Jul 7 '14 at 6:45
7

It's just a warning, which tells you, you didn't set a backend to manage your bibliography, so biblatex uses the fallback biber.

If you want to get rid of the message, you can choose manually between bibtex, bibtex8, bibtexu and biber. Just add backend=xxx in your biblatex line.

Since you didn't modify the code (and hence your outcommented string says it), you should add backend=biber.

See manual, §3.1.1.

UPDATE:

Your error log is not complete. Next time please provide the full error log and the needed bib file (biblioTC.bib).

If I compile, I also get following lines:

Package biblatex Warning: Conflicting options.
(biblatex)                'firstinits' conflicts with 'uniquename=full'.
(biblatex)                Setting 'uniquename=init' on input line 23.

That comes because your chosen style authoryear-comp automatically sets uniquename=full which interferes with your manual uniquename=init. If you remove this setting as well, you should get rid of that message, too.

  • It is just a warning, but it does not print the biblio in the end. I tried to specify which backend to use and I still get empty bibliography. – Stefano_g Jul 6 '14 at 14:18
  • Even if I remove the option, I get empty bibliography. So it is not a problem of conflicting option. – Stefano_g Jul 6 '14 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.