0

Please note the discussion at the end of this thread. After discussing the tex codes \ldots et al, a commenter points out that there is a unicode code point for an ellipsis.

However, on my document (which I'm editing in Lyx), the character prints out in my pdf as something resembling a \cdots code; that is, vertically centered (and in my case, also shifted horizontally to collide with the next word after the whitespace). See the graphic:

cropped output of a text sample. The raw text is "lines of … cultural exchange"

In the pdf file itself, I can copy the ellipsis out, and when I paste it into another document, it remains an ellipsis.

This is undesireable behavior; how do I tell TeX to treat the unicode ellipsis correctly as a baseline ellipsis character, and format it accordingly?

ETA: here is an mwe, which isolates the problem:

\documentclass{article}
\usepackage{xeCJK}
\newfontfamily\zhcn [Path=/usr/share/fonts/arphicfonts/]{uming}
\begin{document}
blah … ... blah
\end{document}

On my system, that outputs the ellipsis character as raised and shifted rightwards. If I drop those two lines from the preamble, the text is correctly formatted. But the xeCJK package shouldn't be called unless I specifically flag something to use it, right?

  • Could we have a minimal working example? – Bernard Jul 6 '14 at 15:16
  • For its working (I don't know exactly why), xeCJK assigns (U+2026) to character class 3; it also defines interchar tokens between classes 0 (default) and 3, with the result that the character is taken from the main CJK font. – egreg Jul 6 '14 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.