44

I am using the default theme, and use the following to customize the footline,

\useoutertheme{infolines}
\setbeamertemplate{footline}{\hspace*{.5cm}\scriptsize{\insertshorttitle
\hspace*{50pt} \hfill\insertframenumber\hspace*{.5cm}}\\
\vspace{9pt}} 

I don't like it also appears on the title page. Is there a simple way not to show it on the first page?

3 Answers 3

38

You can redefine footline locally for the title frame; I also modified the framenumber counter so that the frames including the footline start from one:

\documentclass{beamer}

\useoutertheme{infolines}
\setbeamertemplate{footline}{\hspace*{.5cm}\scriptsize{\insertshorttitle
\hspace*{50pt} \hfill\insertframenumber\hspace*{.5cm}}\\
\vspace{9pt}} 

\author{An Author}
\title{The Title}

\begin{document}

{
\setbeamertemplate{footline}{} 
\begin{frame}
  \titlepage
\end{frame}
}
\addtocounter{framenumber}{-1}

\begin{frame}
A frame with footline
\end{frame}

\end{document}
2
  • 3
    instead of \addtocounter{framenumber}{-1}, you can tag the frames you don't want to count, \begin{frame}[label=intro,noframenumbering]
    – PatrickT
    Dec 16, 2014 at 13:35
  • 2
    Just to add: @PatrickT 's method is actually better, since using \addtocounter{framenumber}{-1} will cause the final slide number to be different from the total number of frames (e.g. when using \insertframenumber and \inserttotalframenumber)
    – LSchoon
    Nov 23, 2015 at 15:18
15

Here is solution via the plain option of frame environment (this solution works even with the ignorenonframetext option).

\documentclass[ignorenonframetext]{beamer}

\useoutertheme{infolines}
\setbeamertemplate{footline}{\hspace*{.5cm}\scriptsize{\insertshorttitle
\hspace*{50pt} \hfill\insertframenumber\hspace*{.5cm}}\\
\vspace{9pt}} 

\author{An Author}
\title{The Title}

\begin{document}

\begin{frame}[plain]
  \titlepage
\end{frame}

\begin{frame}
A frame with footline
\end{frame}

\end{document}
3
  • Please help me. After the same way removing the headline in my titlepage but there is an white space instead of the headline. How to fill it by the same coloes that I am using for my template background. Jun 15, 2014 at 16:02
  • It works for me also with out the ignorenonframetext option.
    – djhurio
    Aug 15, 2014 at 8:38
  • @djhurio This solution works with or without the ignorenonframetext option... Aug 15, 2014 at 8:48
7

If you are using a custom footline with \setbeamertemplate you can actually exclude footline generation right in the template by using the following LaTeX condition structure:

\setbeamertemplate{footline}{
    \ifnum \theframenumber=1
        % This is the title frame, do nothing

    \else
        % These would be all the following frames
        % <<<Your template code goes here>>>
    \fi
}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .