2

This question already has an answer here:

So, with the following code

\documentclass[12pt, russian]{article}

\usepackage{fontspec}
\defaultfontfeatures{Ligatures={TeX},Renderer=Basic}
\setmainfont[Ligatures={TeX,Historical}]{Linux Libertine O}
\setsansfont{Linux Biolinum O}
\setmonofont{Inconsolata}
\usepackage{babel}
\usepackage{cleveref}

  % \tracingall
  % \tracingassigns=5
  % \tracingmacros=2
  % \tracingcommands=2
  % \tracingrestores=1
  % \tracingstats=0
  % \tracingoutput=10
  % \tracinggroups=10
  % \tracingonline0

\begin{document}
123
\end{document}


%%% Local Variables: 
%%% mode: latex
%%% TeX-master: t
%%% End: 

I have the following error

! Undefined control sequence.
\@tempa ^^@-\CYRR \cyri \cyrs 
                            \cyru \cyrn \cyro \cyrk 
l.3 \select@language{russian}

? X

The word 'Risunok' stands for 'Picture' in Russian. (That's the word you get by stripping "\cir"s from what is in the error message.)

Is it a bug? Any help or suggestions?

(As you can conclude by playing with the code it's because of the exact combination in the title of the question - well, it is like so on my machine with fully updated TeX Live 2014).

marked as duplicate by egreg, Andrew Swann, T. Verron, Jesse, Mensch Jul 8 '14 at 12:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Feel free to replace the fonts with ones of your own - it seems not working anyway. – Andrew Zabavnikov Jul 8 '14 at 10:18
  • I get no error if I use \usepackage[russian]{babel} before fontspec and remove the global russian option. – egreg Jul 8 '14 at 10:22
  • Wow! Why did you do that rearrangement? Just the blind hope? – Andrew Zabavnikov Jul 8 '14 at 10:29
  • babel should always go before fontspec (there was a question about this yesterday) and I never put the language as a global option. ;-) However, this probably doesn't solve the issue, because the problem is in the russian option to cleveref that makes several definitions using \cyr? and \CYR? commands. – egreg Jul 8 '14 at 10:35
  • 1
    @LaRiFaRi Not really: here the problem is mainly cleveref – egreg Jul 8 '14 at 10:37