1

I have previously compiled my tex file with images, and everything worked alright. Lastly, I have changed only the text in my tex file and when compiling the pdf I received in error of DVItoPDF due to an image. However I did not modify the image with respect to the previous compilation. I think the problem comes from the font, but I cannot see why it was working before and not anymore

Here is the error message:

"Operand stack:
   --nostringval--   --nostringval--   Arial-Bold
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1910   1   3   %oparray_pop   1909   1   3   %oparray_pop   --nostringval--   1893   1   3   %oparray_pop   1787   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   %array_continue   --nostringval--   1868   3   4   %oparray_pop
Dictionary stack:
   --dict:1167/1684(ro)(G)--   --dict:0/20(G)--   --dict:82/200(L)--   --dict:199/256(L)--
Current allocation mode is local
Current file position is 19565
GPL Ghostscript 9.05: Unrecoverable error, exit code 1
** WARNING ** Filtering file via command -->gs -q -dNOPAUSE -dBATCH -sPAPERSIZE=a0 -sDEVICE=pdfwrite -dCompatibilityLevel=1.4 -dAutoFilterGrayImages=false -dGrayImageFilter=/FlateEncode -dAutoFilterColorImages=false -dColorImageFilter=/FlateEncode -sOutputFile=/tmp/dvipdfmx.Xn9tqR6 ./images/verif_thetaK_multiplot.eps -c quit<-- failed. ** WARNING ** Image format conversion for "./images/verif_thetaK_multiplot.eps" failed...
** ERROR ** pdf_ref_obj(): passed invalid object.

Output file removed."

The image in eps who seems to be the source of error (made using gnuplot).

The answer to gs -q -dNOPAUSE -dBATCH -sPAPERSIZE=a0 -sDEVICE=pdfwrite -dCompatibilityLevel=1.4 -dAutoFilterGrayImages=false -dGrayImageFilter=/FlateEncode -dAutoFilterColorImages=false -dColorImageFilter=/FlateEncode -sOutputFile=/tmp/dvipdfmx.Xn9tqR6 ./images/verif_thetaK_multiplot.eps -c quit

is

Error: /typecheck in /findfont
Operand stack:
   --nostringval--   --nostringval--   Arial-Bold
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1910   1   3   %oparray_pop   1909   1   3   %oparray_pop   --nostringval--   1893   1   3   %oparray_pop   1787   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   %array_continue   --nostringval--   1868   3   4   %oparray_pop
Dictionary stack:
   --dict:1167/1684(ro)(G)--   --dict:0/20(G)--   --dict:82/200(L)--   --dict:199/256(L)--
Current allocation mode is local
Current file position is 19565
GPL Ghostscript 9.05: Unrecoverable error, exit code 1
  • 2
    Yes sorry, the name of the command is "dvipdfmx". I thought DVItoPDF was the name of the command (it is its name in Kile). – lambertmular Jul 8 '14 at 11:06
  • 3
    Do you mind preparing a minimal example and can we see the image in question. That Arial-Bold looks interesting, but it would be nice to have something we can test on our own systems. – daleif Jul 8 '14 at 11:09
  • 1
    The error message suggests there's a problem with the PostScript code in your image file images/verif_thetaK_multiplot.eps. I don't know why editing just the document text should trigger the error (unless, perhaps, the code in the image file hasn't reset the graphics state). What happens if you try to run gs -q -dNOPAUSE -dBATCH -sPAPERSIZE=a0 -sDEVICE=pdfwrite -dCompatibilityLevel=1.4 -dAutoFilterGrayImages=false -dGrayImageFilter=/FlateEncode -dAutoFilterColorImages=false -dColorImageFilter=/FlateEncode -sOutputFile=/tmp/dvipdfmx.Xn9tqR6 ./images/verif_thetaK_multiplot.eps -c quit – Nicola Talbot Jul 8 '14 at 12:21
  • 1
    Perhaps it's related to bugs.debian.org/cgi-bin/bugreport.cgi?bug=732440 – Nicola Talbot Jul 8 '14 at 15:34
  • 1
    GhostScript failed to convert your EPS file ./images/verif_thetaK_multiplot.eps to PDF. Maybe it could not locate a font Arial-Bold used in your EPS file. Please check your GhostScript installation. – user59523 Jul 22 '14 at 21:34
2

Here is a slightly longer comment

This sample file works just fine

\documentclass[a4paper]{memoir}
\usepackage[dvipdfmx]{graphicx}
\begin{document}
\includegraphics{973c6f2954.eps}
\end{document}

compiled using latex and dvipdfmx on TeX Live 2013 (frozen) on Linux.

  • I use your latex code to check and the dvipdfmx part still does not work on my computer. I have the same error message than previously. I am also on linux. – lambertmular Jul 8 '14 at 14:20
  • Which LaTeX distribution? Usually listed in the first line of the .log file – daleif Jul 8 '14 at 14:27
  • The first line of my .log file is This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live 2009/Debian) (format=latex 2013.11.13) 8 JUL 2014 15:17 – lambertmular Jul 8 '14 at 14:35
  • 1
    So basically you are using a LaTeX installation from 2009! A lot has happened since 2009. Please update your LaTeX installation. – daleif Jul 8 '14 at 14:38
  • Also which gs version are you using? Mine is GPL Ghostscript 9.05 on Ubuntu 12.04. – daleif Jul 8 '14 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.