13

Help me, please, to fix the work of biber. When I put in biblatex options backend=biber then during the compilation I get:

This is BibTeX, Version 0.99d (TeX Live 2010)
The top-level auxiliary file: test.aux
I found no \citation commands---while reading file test.aux
I found no \bibdata command---while reading file test.aux
I found no \bibstyle command---while reading file test.aux
(There were 3 error messages)

I just updated my TexLive 2010 at 23.05.2011 by the command tlmgr update --all Maybe I do something wrong? Please, help.

After correction: code added

\documentclass[12pt]{report} 

\usepackage{fontspec}
\usepackage[hidelinks]{hyperref}

\usepackage{xunicode}
\usepackage[no-sscript]{xltxtra}

\usepackage[babel=false]{csquotes}
\usepackage{polyglossia}
\setdefaultlanguage{french}
\setotherlanguages{german,english,greek,polish,russian}
\usepackage[backend=biber,style=verbose-ibid,citepages=suppress,sorting=nty]{biblatex}

\setmainfont[Mapping=tex-text]{Linux Libertine}

\usepackage{setspace}
\usepackage{acronym}
\usepackage{tocloft}

\usepackage{filecontents}

\begin{filecontents}{fortest.bib}

@Book{Kaluzh,
title = {Nowy sobór. Natura, historia przygotowań, tematyka},
author = {Tadeusz Kałużny},
publisher = {wydawnictwo księży Sercanów},
year = {2008},
location = {Krakóv},
}


@Book{AlKarapan,
author = {Αλέξανδρος Κ. Καραπαναγοπούλου},
title = {Η Μεγάλη Σ. της ΟΑΕ},
publisher = {Auto-édition},
year = {1990/1998},
volumes = {6},
location = {Αθήνα},
shorthand = {MS-OAE},
}


@Misc{Konst1923,
title = {Πρακτικὰ καὶ ἀποφάσεις τοῦ ἐν ΚΠΣ (10 μαΐου--8 ἰουνίου 1923)},
year = {1923},
location = {Κωνσταντινούπολη},
keywords = {primary}
}

@Article{Akury,
author = {Adolf Küry},
title = {Die Konferenz in Konstantinople},
journal = {Internationale kirchliche Zeitschrift},
year = {1924},
number = {14},
pages = {62--64}
}

@Online{Tichon1923enciclic,
title = {\textrussian{Послание Патриарха Тихона к православному народу о реформе календаря в РПЦ}},
date = {1923-10-01},
urldate = {2010-10-05},
url = {http://holyrussia.narod.ru/Tykhon_Calendar.html}
}

@Article{Echo1932,
journal = {Échos d'Orient},
title = {Le préconcile orthodoxe},
author = {J. Lacombe},
number = {31},
year = {1932},
pages = {239-241}
}

\end{filecontents}

\addbibresource{conference.bib}


\begin{document}
test\footcite[331]{Kaluzh} est\footcite[23--27]{AlKarapan} test\footcite[23--27]{Konst1923} test\footcite[23--27]{Tichon1923enciclic} test\footcite[23--27]{Echo1932} test test

\printbibliography

\end{document}
7
  • Could you give us an example of the tex file that caused these errors? Did you try deleting all the auxiliary files and recompiling?
    – Seamus
    May 23, 2011 at 12:36
  • check here for a mwe involving greek and english references.
    – pmav99
    May 23, 2011 at 12:40
  • 2
    You are telling biblatex to use Biber, but your log is from BibTeX.
    – Joseph Wright
    May 23, 2011 at 13:14
  • @Seamus I've tried to delete all aux files, but it doesn't help. :( There is a code above.
    – filokalos
    May 23, 2011 at 13:14
  • 'Reverse duped' to a new, canonical, question/answer
    – Joseph Wright
    Oct 26, 2013 at 20:50

2 Answers 2

20

Sometimes (I am not sure why or when) biber gets stuck. It has something to do with running bibtex instead of biber but I haven't pinpointed it. Anyway, if you get a message like

FATAL - Error loading data source package 'Biber::Input::file::bibtex': data source /tmp/par-username/cache-*

then, removing the whole directory should solve the problem.

You can find which directory you must remove by running biber --cache.

In Linux the command is:

 rm -r <directory-name>

Note: Do replace <directory-name> with the output of the command.

In windows, if the problem exists there too, propably the solution will be something similar, I haven't checked it though.

Update (after PLK's comment)

For more info look at the biber manual (sec. 3.1).

5
  • This is usually due to the way Biber is 'packed' for portability. On first run, it has to extract various bits of code, and if this goes wrong or gets interrupted then you get errors like the one seen.
    – Joseph Wright
    May 23, 2011 at 15:47
  • 4
    See section 3.1 of the biber manual - it explains this and gives the common locations on various OSes of the par archive folder you can delete to fix it.
    – PLK
    May 26, 2011 at 17:07
  • @PLK I really can't find the folder for my Windows machine in the manual. Is there a certain folder or file name to be deleted? If so, please reply the name, then I can let Windows search for the file.
    – Erik
    Apr 15, 2014 at 19:26
  • 1
    Run biber --cache and it will tell you the location.
    – PLK
    Apr 16, 2014 at 5:46
  • In case it's helpful for someone: even after correctly configuring VSCode + LaTeX-Workshop with biber as biblatex backend, I still got some errors like "I found no \citation commands BibTeX". What was still using bibtex backend and failing was the LaTeX-Workshop intellisense tool. So either set in VSCode general settings or in a .vscode/settings.json file the following option: "latex-workshop.intellisense.citation.backend": "biblatex"
    – Zitoun
    Dec 7, 2023 at 8:45
11

Well if you tell biblatex that you intend to use the backend biber (backend=biber) then you should do it and not call bibtex. With backend=biber biblatex puts the informations in a bcf file and not in the aux so it is not a surprise that bibtex can't find them.

10
  • Thank you Could you please tell me more detailed? I'm not very common with this theme. So what should I do?
    – filokalos
    May 23, 2011 at 13:20
  • Use biber instead of bibtex. May 23, 2011 at 13:26
  • @Ulrike Fischer I've tried. It writes "FATAL - Error loading data source package 'Biber::Input::file::bibtex': data source /tmp/par-filokalos/cache-6a1f654c9b57c7ffeb35998422a4089cb0e12294/inc/lib/Biber/Input/file/bibtex.dcf not found in ."
    – filokalos
    May 23, 2011 at 13:32
  • I don't have texlive so I can't help you in debugging its biber version. May 23, 2011 at 13:46
  • Ok. Thank you for help. At least now I know where is the problem.
    – filokalos
    May 23, 2011 at 13:56

Not the answer you're looking for? Browse other questions tagged .