4

Lots of old academic papers are distributed in ps.gz format. On Linux, after gunzip, I usually just run ps2pdf on the file, but the result is almost unreadable on Android phones and tablets: characters look like little dots, as if the font is not recognized. I tried several options such as -dSubetAllFonts=True or -dEmbedAllFonts=True, but nothing seems to work. Is there a way to convert those old papers in such a way that the font is acceptable for most modern systems (and Android in particular)?

7
  • can you give an example of such articles? By the way, Android is off-topic for here so SU-SE would be the place. But we might maybe (and that's a long stretch) get an answer about better handling of PS files. – percusse Jul 8 '14 at 21:02
  • Here is one example that I've been trying to convert just now: pllab.is.ocha.ac.jp/~asai/papers/thesis.ps.gz – namin Jul 8 '14 at 21:10
  • Related: tex.stackexchange.com/questions/120260/… – Henri Menke Jul 8 '14 at 21:12
  • I saw that, but when I run pkfix-helper asai_thesis.ps, I get Reading asai_thesis.ps ... done. Total number of Type 3 fonts encountered: 0 pkfix-helper: No Type 3 fonts were encountered in the input file and all the fonts (except for the one Japanese subtitle, which is the only readable text) are just none in the final pdf output. – namin Jul 8 '14 at 21:17
  • @namin If I do ps2pdf thesis.ps and preview the PDF file, I clearly see Type3 fonts. This is confirmed by pdffonts thesis.pdf. The problem for pkfix-helper is that these fonts are nameless – egreg Jul 8 '14 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.