2

I'm formatting a dissertation and need a small, vertical space after my footrule before the start of my first footnote, but no space between the footnotes which follow. I've tried the following command: \renewcommand{\footnotesep}{3\baselineskip} ... And had good success with the space between the footrule and the first footnote, but messed up my spacing between all other footnotes on the same page. Any suggestions? Thanks!

2
  • Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. You can have a look at our starter guide to familiarize yourself further with our format.
    – user31729
    Jul 9, 2014 at 20:32
  • 3\baselineskip means the vertical space of 3 lines, that is definitely no small space...You forgot to reset the \footnotesep to its standard value and I am also not sure, that \footnotesep is the length you should change...
    – user31729
    Jul 9, 2014 at 20:34

1 Answer 1

3

\footnoterule is defined (in latex.ltx) to occupy exactly the height of the rule vertically:

\def\footnoterule{\kern-3\p@
  \hrule \@width 2in \kern 2.6\p@} % the \hrule is .4pt high

as you have already discovered, \footnotesep is inserted above every footnote on a page.

i think the most reliable way of inserting additional space just below the footnote rule is to increase the kerned distance below the rule itself. this is the approach taken in the ams document classes, where the definition is

\def\footnoterule{\kern-.4\p@
    \hrule\@width 5pc\kern11\p@\kern-\footnotesep}

all the kerns here are vertical, since none of the commands enter horizontal mode.

edit: these definitions use the "internal" command \p@ for pt, so redefinition must be done between \makeatletter ... \makeatother. (even if \p@ is replaced by pt, this is still necessary because another "internal" command, \@width is used in the definition.)

3
  • Thanks very much for your quick response. I've tried to implement this using the \renewcommand{} option, but haven't had much luck. I apologize for my ignorance on this one, but how would I redefine the kerns? Thanks in advance!
    – Jonathan
    Jul 10, 2014 at 14:11
  • 1
    @Jonathan -- i'm not sure whether the problem is dealing with @ signs in the command names, but realizing that someone relatively new to this enterprise might not realize that, i edited the answer. (so the kern after the rule could be represented by either \kern15\p@ or \kern15pt; those are equivalent.) if the problem is something else, please say what you're getting -- an error message, perhaps? Jul 10, 2014 at 14:41
  • Once again, thanks for your quick reply. I had tried switching out the \p@ with pt, but had entirely ignored the @width. Still though, I'm quite ignorant on what the proper command should be. After your last post, I tried using: \makeatother{\def\footnoterule{\kern-.9\p@ \hrule\@width 5pc\kern17\p@\kern-\footnotesep}} and got the following error message: ! LaTeX Error: Option clash for package setspace. Thanks again for your help, and I apologize for the trouble.
    – Jonathan
    Jul 10, 2014 at 15:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .