0

I haven't used JabRef in a long time, basically ever since I moved from Microsoft OS to Mac. Now I am writing my dissertation in LaTeX, and whenever I refer to an entry in my old .bib bibliography, the format of German umlauts (ä, ü, ö etc.) is totally messed up. How do I change the encoding in my BibTeX file? I use

\usepackage[applemac]{inputenc}

in my preamble, and apart from the bibliography problem, everything works perfectly.

Here is my MWE:

\documentclass[11pt,twoside]{report} 
\usepackage[natbib,style=authoryear-comp, url=false, doi=false,isbn=false,eprint=false]{biblatex} 
\bibliography{[mypath]} %this works 
\begin{document} Here I want to refer to \cite{Lueger1995}. 
\end{document} 

and here one of those problematic bib-items:

@Book{Lueger1995, 
Title = {{Pressesprache}}, 
Author = {Heinz-Helmut Lüger}, 
Publisher = {Max Niemeyer Verlag, Tübingen}, 
Year = {1995}, } 
2
  • 1
    Welcome to TeX.SX! You should provide a little example which shows your problem. It has to be compilable and include one of the problematic bib-items.
    – LaRiFaRi
    Commented Jul 14, 2014 at 10:57
  • Thanks! So here is one of those problematic bib-items: @Book{Lueger1995, Title = {{Pressesprache}}, Author = {Heinz-Helmut Lüger}, Publisher = {Max Niemeyer Verlag, Tübingen}, Year = {1995}, } and the way I refer to it would be \documentclass[11pt,twoside]{report} \usepackage[natbib,style=authoryear-comp, url=false, doi=false,isbn=false,eprint=false]{biblatex} \bibliography{[mypath]} %this works \begin{document} Here I want to refer to \cite{Lueger1995}. \end{document}
    – frauroth
    Commented Jul 14, 2014 at 11:05

1 Answer 1

1

You shouldn't use applemac encoding for .tex files any more! All modern OS understand UTF8 and, with ascii, it is the only universal format. I have no idea why the default in TeXshop still is applemac, if I'm not mistaken.

You also can use UTF8-encoded .bib files if you make your bibliography with biblatex/biber, and JabRef is able to save your .bib files in UTF8 encoding (goto Preferences -> General menu).

4
  • Thanks Bernard. I tried that. But when I change applemac encoding to utf8, then it won't even compile anymore, let alone work with references.
    – frauroth
    Commented Jul 14, 2014 at 11:40
  • @frauroth: You need to change the encoding of the files themselves. You could also try to you use bibencoding=ansinew in the biblatex options (assuming that your bib file is ansinew encoded). Commented Jul 14, 2014 at 11:49
  • It's probably because you haven't converted your file to utf8 format. The real encoding must be the same as the declared encoding! Do you not have a security copy of your files? Or you haven't converted correctly. iconv does the conversion as a another file and is available for Linux and MacOS X; the problem is that you must be sure of the original encoding.
    – Bernard
    Commented Jul 14, 2014 at 11:50
  • 1
    @frauroth: Fine. Nevertheless in the long run you should better reencode all your files in utf8. That's easier than a mix of various encodings and will also make it easier to use your files on other OS. Commented Jul 14, 2014 at 12:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .