6

I haven't seen a question on this website that deals with hiding watermarks with xwatermark. Here's the preamble of the document I'm working on that is relevant:

\usepackage[printwatermark]{xwatermark}
\newwatermark*[page=1, textmark=]{}
\newwatermark*[allpages,color=gray,angle=0,scale=1,xpos=46,ypos=-134]{Some watermark}

In section 3.2 of the documentation:

If you issue any of the statements

page=x 
pages=x-y 
pagex={x,y,z} 
firstpage 
lastpage 
allpages=true 
evenpages=true 
oddpages=true

together with printwatermark=true but you don’t want the mark on any particular page, we can simply set \newwatermark[other keys,textmark=]{} or, to the same effect, we may set \newwatermark[other keys]{}, where ‘other keys’ may include the page specifiers.

I'm trying to hide the watermark for the first page. As you see in the code above, I have \newwatermark*[page=1, textmark=]{}. I have also tried using firstpage instead of page = 1, and I have also tried placing this line after \newwatermark*[allpages,color=gray,angle=0,scale=1,xpos=46,ypos=-134]{Some watermark}.

Can someone explain what I'm doing wrong?

MWE: as far as I could tell, this is the minimum necessary to get the watermark to look exactly how I need it to.

\documentclass[11pt]{article}
\usepackage[margin=2cm]{geometry}
\usepackage{tikz}
\usepackage[version=3]{mhchem}
\usepackage [english]{babel}
\usepackage[printwatermark]{xwatermark}\newwatermark*[pages=2-,color=gray,angle=0,scale=1,xpos=46,ypos=-134]{\footnotesize Copyright \textcopyright\:2014 by some company.}
\begin{document}
Stuff
\newpage 
More stuff
\end{document}

Received an error, as mentioned in the comments: No end-page for page-range of watermark: ||||I have used the default end-page '5' instead.

3
  • I don't know the package but can you say something like page=2- rather than allpages for the watermarked case? Otherwise, please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – cfr
    Jul 15, 2014 at 2:47
  • It gives me an error " No end-page for page-range of watermark: ||||I have used the default end-page '5' instead. when I do 2-. I will post up a MWE probably sometime tomorrow. Jul 15, 2014 at 4:24
  • MWE has been posted. Jul 15, 2014 at 4:57

1 Answer 1

5

You can skip the first page by selecting the pages

..., page=2-\lastdocpage, ...

in your options. \lastdocpage references the last page in the document.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .