I get lots of errors when compiling (XeLaTeX, from up-to-date MiKTeX 2.9 x64, TeXstudio 2.8.0, Windows 8 x64) the friggeri-cv template. Download it here: http://www.latextemplates.com/template/friggeri-resume-cv .

The errors:

  • Missing endcsname inserted
  • You can't use dimexpr in math mode. \begin{entrylist}
  • Extra endcsname. \begin{entrylist}
  • Missing font identifier. \begin{entrylist}
  • Math formula deleted: Insufficient symbol fonts. \end{entrylist}

All errors show up multiple times and I can not find any clues on their origin when looking around on the internet. The strange thing is that this CV did compile without errors in the past and I have adapted it for my personal use. My adaptation also compiled without problems.

Now, I got many errors when compiling my CV (it has been a month or so since the last compile). So I tried compiling the default template to see whether it was my bad or not: I get the same errors. It appears either the template is not working any-more, or my (Xe)LaTeX installation is broken/bugged.

I have also tried changing the fonts in the .cls file to Arial, but no luck there (I have Helvetica Neue installed, tough, and the font has worked for me before with this template).

Have there been updates to packages in the last month, making the template unusable? Or is there a problem with my PC?

Any help or thoughts are appreciated! Thanks.

There are no errors when compiling when I disable alle entrylist environments and the line containing the $\varheartsuit$.

As requested in a comment below: I can compile a pretty simple .tex file with both pdflatex and xelatex without errors, so both compilers can do their job.

Another request from the comments: the .log file containing the errors I get when running xelatex on the default Friggeri template:

  • 1
    "The strange thing is that this CV has compiled error-free for me in the past" : in the present too, so. + "borked" = "broken"? + I can compile the fresh, untouched template (This is XeTeX, Version 3.14159265-2.6-0.99991 (TeX Live 2014) (preloaded format=xelatex 2014.7.9)).
    – Clément
    Jul 15, 2014 at 18:46
  • 1
    Can you compile any other .tex file, with pdflatex, with XeLaTex?
    – Clément
    Jul 15, 2014 at 18:47
  • 1
    I did'nt know the expression "borked", I don't mind slang. + you don't have to add a MWE of what you can compile : simply remove it, and remove the "Or is there a problem with my PC?" question : you now answered that part. + maybe you should copy/paste the .log file resulting of the compilation of the untouched template.
    – Clément
    Jul 16, 2014 at 9:06
  • 1
    @Erik The Missing \endcsname error is due to a bug in fontspec that has been solved by now: update the package with MiKTeX's package manager. See tex.stackexchange.com/questions/186690/…
    – egreg
    Jul 16, 2014 at 13:31
  • 1
    I was wrong: it's unicode-math the culprit: the current version is 2014/06/30 v0.7f
    – egreg
    Jul 16, 2014 at 15:23

1 Answer 1


@egreg posted the solution:

\RequirePackage{fixltx2e} needs to be put before \documentclass{...} until an update fixes unicode-math.

This has fixed my problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .