1

I'm using the glossaries package and defining my acronyms like this:

\newacronym{led}{LED}{Light Emitting Diode}

I'm then using the acronyms in my document with either

\gls{led}

or

\glspl{led}

depending on whether I want them to be plural or singular. If the first reference to the acronym is singular then it will result in "Light Emitting Diode (LED)". If the first reference is plural then it will result in "Light Emitting Diodes(LEDs)". There is no space between the s in "Diodes" and the '('. Is there an easy way to change this behavior to include a space like it does in the singular case?

EDIT:

I tried making a simple example to compile and interestingly it doesn't exhibit the same behavior:

\documentclass{article}

\usepackage[acronym]{glossaries}
\makeglossaries

\newacronym{led}{LED}{Light Emitting Diode}
%this is a potential work around if the problem does come up:
%\newacronym[longplural=Light Emitting Diodes ]{led}{LED}{Light Emitting Diode}

\begin{document}

First use is plural: \glspl{led}.
Second use is plural:\glspl{led}.

\printglossaries

\end{document}

I'll have to look into it in more depth to understand what's causing the behavior I'm seeing in the non-trivial example. If this ever comes up in a search engine then please note the workaround I put in the above example.

  • 2
    Welcome to TeX.SX! Please make your code compilable (if possible), or at least complete it with \documentclass{...}, the required \usepackage's, \begin{document}, and \end{document}. That may seem tedious to you, but think of the extra work it represents for TeX.SX users willing to give you a hand. Help them help you: remove that one hurdle between you and a solution to your problem. – Adam Liter Jul 15 '14 at 18:57
  • 1
    Ok, thanks for letting me know so politely. I added a compileable example and will be sure to do so in the future. – foob Jul 15 '14 at 19:15
  • Compiling your example gives the correct version: Light Emitting Diodes (LEDs) [MikTeX2.9]. – Przemysław Scherwentke Jul 15 '14 at 19:23
  • What version of glossaries are you using? – Nicola Talbot Jul 15 '14 at 20:00
  • This is probably related to bug report 54. – Nicola Talbot Oct 7 '14 at 17:54
3

Had the same problem. I resolved it by declaring the acronyms in the head instead within the document environment. See: section "Drawbacks With Defining Entries in the Document Environment" of the user manual

  • 2
    This is a link only answer... links can be 'dead' in future. I suggest to elaborate on this answer a little bit. Welcome to TeX.SX! – user31729 Oct 7 '14 at 13:22
  • 1
    Welcome to TeX.SX! I replaced your link with a generic CTAN mirror link. You're correct that the solution is obtained by moving the definitions to the preamble. Although the bug is now fixed, this is the better option. – Nicola Talbot Oct 9 '14 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.