1

So, I have an interesting problem with a really (really really ...) large equation that I am trying to typeset. Basically, crunching the file through pdflatex gives:

    This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014/W32TeX) (preloaded format=pdflatex)
    restricted \write18 enabled.
    entering extended mode
    (./test5.tex
    LaTeX2e <2014/05/01>
    Babel <3.9k> and hyphenation patterns for 79 languages loaded.
    (c:/texlive/2014/texmf-dist/tex/latex/base/article.cls
    Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
    (c:/texlive/2014/texmf-dist/tex/latex/base/size10.clo))
    (c:/texlive/2014/texmf-dist/tex/latex/geometry/geometry.sty
    (c:/texlive/2014/texmf-dist/tex/latex/graphics/keyval.sty)
    (c:/texlive/2014/texmf-dist/tex/generic/oberdiek/ifpdf.sty)
    (c:/texlive/2014/texmf-dist/tex/generic/oberdiek/ifvtex.sty)
    (c:/texlive/2014/texmf-dist/tex/generic/ifxetex/ifxetex.sty))
    (c:/texlive/2014/texmf-dist/tex/latex/amsmath/amsmath.sty
    For additional information on amsmath, use the `?' option.
    (c:/texlive/2014/texmf-dist/tex/latex/amsmath/amstext.sty
    (c:/texlive/2014/texmf-dist/tex/latex/amsmath/amsgen.sty))
    (c:/texlive/2014/texmf-dist/tex/latex/amsmath/amsbsy.sty)
    (c:/texlive/2014/texmf-dist/tex/latex/amsmath/amsopn.sty))
    (c:/texlive/2014/texmf-dist/tex/latex/amsfonts/amssymb.sty
    (c:/texlive/2014/texmf-dist/tex/latex/amsfonts/amsfonts.sty)) (./test5.aux)
    *geometry* driver: auto-detecting
    *geometry* detected driver: pdftex
    (c:/texlive/2014/texmf-dist/tex/latex/amsfonts/umsa.fd)
    (c:/texlive/2014/texmf-dist/tex/latex/amsfonts/umsb.fd)
    Overfull \hbox (8381.87427pt too wide) detected at line 110
    [] \OMS/cmsy/m/n/10 ^^@ [] [] ^^@ [] [] ^^@ [] [] ^^@ [] []

    Overfull \hbox (8377.93834pt too wide) detected at line 114
    \OT1/cmr/m/n/10 0 \OMS/cmsy/m/n/10 ^^@ [] [] ^^@ [] [] ^^@ [] [] ^^@ [] []

    Overfull \hbox (8331.86671pt too wide) detected at line 118
    \OT1/cmr/m/n/10 0 \OMS/cmsy/m/n/10 ^^@ [] [] ^^@ [] [] ^^@ [] [] ^^@ [] []

    Overfull \hbox (7988.59111pt too wide) detected at line 122
    \OT1/cmr/m/n/10 0 \OMS/cmsy/m/n/10 ^^@ [] [] ^^@ [] [] ^^@ [] [] ^^@ [] []

    Overfull \hbox (5905.06718pt too wide) detected at line 126
    \OT1/cmr/m/n/10 0 \OMS/cmsy/m/n/10 ^^@ [] [] ^^@ [] [] ^^@ [] [] ^^@ [] []
    [1{c:/texlive/2014/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
    Overfull \hbox (8873.18288pt too wide) detected at line 210
    [] \OMS/cmsy/m/n/10 ^^@ [] [] ^^@ [] [] ^^@ [] [] ^^@ [] []
    [2] (./test5.aux) )
    (see the transcript file for additional information)<c:/texlive/2014/texmf-dist
    /fonts/type1/public/amsfonts/cm/cmex10.pfb><c:/texlive/2014/texmf-dist/fonts/ty
    pe1/public/amsfonts/cmextra/cmex7.pfb><c:/texlive/2014/texmf-dist/fonts/type1/p
    ublic/amsfonts/cm/cmmi10.pfb><c:/texlive/2014/texmf-dist/fonts/type1/public/ams
    fonts/cm/cmmi5.pfb><c:/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/cm/c
    mmi7.pfb><c:/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/cm/cmr10.pfb><
    c:/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/cm/cmr5.pfb><c:/texlive/
    2014/texmf-dist/fonts/type1/public/amsfonts/cm/cmr7.pfb><c:/texlive/2014/texmf-
    dist/fonts/type1/public/amsfonts/cm/cmsy10.pfb><c:/texlive/2014/texmf-dist/font
    s/type1/public/amsfonts/cm/cmsy5.pfb><c:/texlive/2014/texmf-dist/fonts/type1/pu
    blic/amsfonts/cm/cmsy7.pfb>
    Output written on test5.pdf (2 pages, 582701 bytes).
    SyncTeX written on test5.synctex.gz.
    Transcript written on test5.log.

Increasing the dimensions of the paper seems to hit a limitation somewhere...

    This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014/W32TeX) (preloaded  format=pdflatex)
     restricted \write18 enabled.
    entering extended mode
    (./test5.tex
    LaTeX2e <2014/05/01>
    Babel <3.9k> and hyphenation patterns for 79 languages loaded.
    (c:/texlive/2014/texmf-dist/tex/latex/base/article.cls
    Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
    (c:/texlive/2014/texmf-dist/tex/latex/base/size10.clo))
    (c:/texlive/2014/texmf-dist/tex/latex/geometry/geometry.sty
    (c:/texlive/2014/texmf-dist/tex/latex/graphics/keyval.sty)
    (c:/texlive/2014/texmf-dist/tex/generic/oberdiek/ifpdf.sty)
    (c:/texlive/2014/texmf-dist/tex/generic/oberdiek/ifvtex.sty)
    (c:/texlive/2014/texmf-dist/tex/generic/ifxetex/ifxetex.sty))
    ! Dimension too large.
    <to be read again> 
               \relax 
    l.15 \geometry{papersize={25000pt,60in}}

Here's the paper size section of the file...

    \usepackage{geometry}
    \geometry{papersize={25000pt,60in}}

I've tried specifying long lengths in inches and points. Thoughts on how to push the limits of page/layout size further?

4
  • My Adobe Reader can only show up to 200in x 200in (even though you try something not-too larger). Ultimately you can go as far as \maxdimen though.
    – Werner
    Jul 16, 2014 at 6:09
  • that must be a hell of an equation :P
    – musicman
    Jul 16, 2014 at 6:20
  • 1
    If you use 25000pt as width, this means about 340in or more than 8m.... Do you have found the grand unified theory formula and want to typeset it? ;-)
    – user31729
    Jul 16, 2014 at 6:24
  • 1
    As others note, the size of the equation here is large to the point of not being credible. That suggests something else is going on: can you cut down your input to a MWE that we can actually test?
    – Joseph Wright
    Jul 16, 2014 at 7:13

1 Answer 1

4

According to page 58 of the TeXBook:

TeX will not deal with dimensions whose absolute value is 230 sp or more. In other words, the maximum legal dimension is slightly less than 16384 pt. This is a distance of about 18.892 feet (5.7583 meters), so it won’t cramp your style.

Your overfull hboxes are no larger than 9000pt, so a width of around 9500pt should work. As others have noted, it is unlikely that you really have an equation that needs paper that large.

1
  • 1
    "230 sp" didn't make any sense, so i added the code to indicate the power to which 2 is raised. also fixed the page number. looks like you cut-and-pasted from a pdf copy of the book, which is a bad thing ^{(\TM)} since the texbook isn't to be tex'ed (please see knuth's tex & mf page, the section entitled "copyright infringement"). the tex live distribution contains the file texbook.tex, from which the relevant text can be cut-and-pasted accurately (although some slight editing may be desirable) and honorably. Jul 16, 2014 at 11:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .