1

I'm writing an IEEE paper and I wanted to use the IEEEtran bibliography style for my research paper. I used the following code to add the bibliography

\documentclass[conference]{IEEEtran}
\title{Title}
}
\begin{document}
\bibliographystyle{IEEEtran}
\bibliography{myreferences}
\end{document}

When I compile the code using PDFLatex for first time it will not generate any error, infact it generates a new file called myPaper.bbl and when I compile the document for second time I get the following error

./myPaper.bbl:3:Something's wrong--perhaps a missing \item. \end{thebibliography}

The contents of myPaper.bbl are

% Generated by IEEEtran.bst, version: 1.13 (2008/09/30)
\begin{thebibliography}{}
\providecommand{\url}[1]{#1}
\csname url@samestyle\endcsname
\providecommand{\newblock}{\relax}
\providecommand{\bibinfo}[2]{#2}
\providecommand{\BIBentrySTDinterwordspacing}{\spaceskip=0pt\relax}
\providecommand{\BIBentryALTinterwordstretchfactor}{4}
\providecommand{\BIBentryALTinterwordspacing}{\spaceskip=\fontdimen2\font plus
\BIBentryALTinterwordstretchfactor\fontdimen3\font minus
  \fontdimen4\font\relax}
\providecommand{\BIBforeignlanguage}[2]{{%
\expandafter\ifx\csname l@#1\endcsname\relax
\typeout{** WARNING: IEEEtran.bst: No hyphenation pattern has been}%
\typeout{** loaded for the language `#1'. Using the pattern for}%
\typeout{** the default language instead.}%
\else
\language=\csname l@#1\endcsname
\fi
#2}}
\providecommand{\BIBdecl}{\relax}
\BIBdecl

\end{thebibliography}

One more observation I made is, if I change the style of bibliography from IEEEtran to plain, in this case also I notice the same error.

After doing this change what I understood is, the problem is not with the IEEEtran file or plain style file, the only problem is because of the myPaper.bbl file which is being created automatically.

I couldn't understand about the problem more than this as my knowledge in kile documents is limited.

Could someone please help me solve this issue.

3
  • Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – Johannes_B
    Jul 16 '14 at 8:45
  • 2
    I bet there is an entry in your bib-file responsible (maybe an anescaped %). Try to find tis entry using the techniques described in the link above.
    – Johannes_B
    Jul 16 '14 at 8:47
  • 2
    Thanks for the MWE, but the faulty bib part is missing ;-)
    – Johannes_B
    Jul 16 '14 at 8:54
1

My current version of IEEEtran expects the biblatexpackage. This works with current TeXLive 2014:

\documentclass[conference]{IEEEtran}
\usepackage{biblatex}
\addbibresource{IEEEexamples}
\title{Title}

\newcommand\BibTeX{Bib\TeX}
\begin{document}
\nocite{*}
\printbibliography
\end{document}

I run pdflatex -> biber -> pdflatex -> pdflatex

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.