1

I want to add a dot below í, like this: "ị́."

I am using XeLaTeX, with fontspec. My code looks like this:

\documentclass{article}
\usepackage{fontspec}
\setmainfont{CMUSerif-Roman}
\begin{document}
\d{\'{i}}
\end{document}

When I use Computer Modern Unicode font, the result glyph has the acute accent symbol over the original dot of i. From top to down are, acute accent symbol, dot, line and dot (the dot below \d) respectively.

When I switched the font to Times, everything works fine.

I also tried Unicode combining diacritic which works fine in other apps (TextEdit and Safari on Mac, for example) but failed in XeLaTeX.

When I tried to copy the nested glyph from output PDF directly, the paste is "i, COMBINING DOT BELOW, COMBINING ACUTE ACCENT", even if the original sequence is "i, COMBINING ACUTE ACCENT, COMBINING DOT BELOW". It seems that "i" combines with "DOT BELOW" first, making the ligature í unmatched.

How to solve this problem?

  • I tried with LuaLaTeX and it works, but with XeLaTeX the I see the problem. – egreg Jul 19 '14 at 18:20
  • It seems a font dependent problem. I get contradictory results by changing the font. :-( – egreg Jul 19 '14 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.