21

I'm trying to enlarge the interword spacing, because with ITC Kabel's default spacing it's sometimes hard to decide where is the space between two words. I read the manual of the microtype package, and I did some trying, without success. For example this one:

\usepackage{microtype}
\SetTracking[ spacing = {1000*,1666, } ]{ encoding = T1, family = *, shape=*,series=*}{ 25 }

Maybe there is an easy solution that doesn't involve microtype?.

21

You can change the \fontdimen parameters controlling the interword spacing: \fontdimen2 (the normal interword space), \fontdimen3 (the amount of stretch of the interword space), and \fontdimen4 (the amount of shrink). A lttle example:

\documentclass{article}
\usepackage{lipsum}
\begin{document}

\lipsum[1]

\spaceskip=1.5\fontdimen2\font plus 1.5\fontdimen3\font
minus 1.5\fontdimen4\font

\lipsum[1]

\end{document}
  • To be clear about this example: we can set \spaceskip to set the interword glue, whose default values (ideal, stretch, shrink) are picked up from the font's (\fontdimen2, \fontdimen3, \fontdimen4). – ShreevatsaR Jul 19 '17 at 0:14
  • Related question: tex.stackexchange.com/questions/23921/… – ShreevatsaR Nov 6 '17 at 1:09
8

If you are using XeLaTeX or LuaLaTeX, you can use the WordSpace option in fontspec:

\fontspec[WordSpace=1.0]{Times New Roman}
  • Thank you, that time I was using PDFLaTeX, but still thanks! – deeenes Sep 22 '14 at 21:56
  • Please note that this only works while loading a font and not with \addfontfeature. – Tobi Jun 17 '17 at 7:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.