1

I'm using the natbib package and the plainnat style. Also I'm using the url package.

\usepackage[authoryear,round]{natbib}
\usepackage{url}    
\bibliographystyle{plainnat}

My problem is the following:

I want to include several online references, with the url and date of access "printed" in my references. I've read some of the answers given to similar questions, and the majority suggest to use write the date of access in the note field, instead of in the urldate fiel. I would like to know if there is another way to do so, because it's a bit complicated for me to change all dates of access from the urldate fiel to note field by hand. Is there a way to create a command in the preamble which automatically print the date of aceess in the references which have the date on the urldate field?

This is one example of a biblio entrance (automatically generated by reference manager software) with information on the urldate field, which is not printed in the pdf version:

@misc{REN2013,
author = {REN},
booktitle = {Daily Statistics},
title = {{Electricity Real Time Information}},
url = {http://www.centrodeinformacao.ren.pt/EN/},
urldate = {06-01-2014},
year = {2013}
}

I'm not sure whether I'm using Biblatex. According to my editor I'm using it, but I can't understand.

I would appreciate your suggestions to solve my problem. Thank you

  • A field named urldate is not recognized -- and hence not processed -- by the plainnat bibliography style. However, if you change the name of the field from urldate to note, you should be in business. By the way, for entries of type @misc the field booktitle won't get processed either. Is there a way you can get the reference management software to either use a different field type or different fields? Finally, if you're loading the natbib package and execute a \bibliographystyle directive, you're more than likely not using biblatex. – Mico Jul 22 '14 at 20:50
  • Ok, I will not use the note field. About the booktitle, I didn't notice it before, but it's not beeing processed. And about my reference manager, there is no option to change the way the bib file is generated or the fields that are used. In terms of using the biblatex, as I said I didn't know if I was using it or not. According to your comment I understood not. Considering this, how can I make the date of access to appear? If I change to biblatex would it be easier? – Catarina Jul 22 '14 at 21:16
  • Just curious: Why won't you change the name of the field from urldate to note? – Mico Jul 22 '14 at 21:19
  • Sorry, I misunderstood the meaning of "being in business". I will give that option a try so. Thank you again. Is there a way to write a command which changes all the urldate fields to note fields? And if I change change the field from urldate to note, the expression "accessed:" will not appear. I have to write it manually – Catarina Jul 22 '14 at 21:23
  • 2
    It's uncertain whether plainnat will place the note conatining the urldate field at the right place (just after the url). The same problem happened these days with ieee bib style. The simplest way to go would be to use biblatex, which knows urldate and has a natbib compatibility mode. See my answer to this question here: tex.stackexchange.com/questions/192548/… – Bernard Jul 22 '14 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.