1

I have been working on a package in which to place all layout codes for my thesis. Here I also define the Biblatex codes. I am, however, having some trouble with getting biblatex to function properly.

I edit in TexStudio, and this editing software usually suggest codes as I start typing them. Specifically for citations, I get a box of all possible citations matching my entries as I type. I am sure many of you are familiar with this. TexStudio does that when I use "article" class with biblatex, but not with memoir and my own "package".

I was hoping someone experienced could take a quick look and see if they find something that may cause the problem. I use biber as the backend, and I have set TexStudio for this option, and specified in loading biblatex. The package file is not very large (about 100 lines).

I have made a MWE, and I also post here the entire content of my package. That way you can just copy the lines, past them into a new document and save as a .sty file, and you should be good to go - I cannot upload files here. I also post the content of my .bib file, for you to copy-past.

I appreciate any help on the issue!

.tex file:

\documentclass{memoir}

%\usepackage[backend=biber]{biblatex}
\usepackage{assignments}
\addbibresource{refs.bib}
\begin{document}

\chapter{Hello World}
Here I make a preposterous claim, which is supported by \textcite{kelleher2000idpt}.

\printbibliography
\end{document}

.bib file

@article{kelleher2000idpt,
    Author = {P. Kelleher AND K. Pacheco AND L. S. Newman},
    Date = {2000},
    Date-Added = {2014-04-27 13:12:26 +0000},
    Date-Modified = {2014-07-23 17:03:42 +0000},
    Journaltitle = {Environmental Health Perspectives},
    Number = {4},
    Pages = {685 -- 696},
    Read = {0},
    Title = {Inorganic dust pneumonias: the metal-related parenchymal disorders},
    Volume = {108},
    }

.sty file

% Declare that this style file requires at least LaTeX version 2e.
\NeedsTeXFormat{LaTeX2e}

% Provide the name of your page, the date it was last updated, and a comment about what it's used for
\ProvidesPackage{assignments}[]

%=============================================================================
% PACKAGES AND SETTINGS

\RequirePackage[backend=biber, style=authoryear-comp, maxbibnames=99, firstinits=true, hyperref=true]{biblatex}

        % remove the "In:" preceeding the journal name
        \renewbibmacro{in:}{%
        \ifentrytype{article}{}{\printtext{\bibstring{in}\intitlepunct}}}

        % add space between bibliography entries by 50 %
        \setlength\bibitemsep{1.5\itemsep}
        \addbibresource{refs.bib}


%\RequirePackage{}
%\RequirePackage{}
%\RequirePackage{}
%\RequirePackage{}
\RequirePackage{caption}
            \captionsetup[figure]{labelfont={color=PineGreen,bf},textfont=up,labelsep=period,format=hang,font=small}
            \captionsetup[table]{labelfont={color=PineGreen,bf},textfont=up, labelsep=period,format=hang,font=small}

\RequirePackage{minitoc}

\RequirePackage[american]{babel}
\RequirePackage[fulloldstylenums]{kpfonts}
\RequirePackage[utf8]{inputenc}
\RequirePackage{amsfonts,amsmath,cancel,dsfont,textgreek}
\RequirePackage{csquotes}
\RequirePackage{lettrine}
\RequirePackage[usenames,dvipsnames]{color}
\RequirePackage{lipsum}
\RequirePackage{subfig}
\RequirePackage{pdfpages}
\RequirePackage{float}
\RequirePackage{rotating}
\RequirePackage{pbox}
\RequirePackage{chemformula}
\RequirePackage{threeparttable} 
\RequirePackage{hyperref}
\hypersetup{
    pdfborder = {0 0 0},
    colorlinks,
    linktocpage = true,
    citecolor=PineGreen,
    filecolor=PineGreen,
    linkcolor=PineGreen,
}
\RequirePackage{calc}

%=======================

% defining the chapter style
\renewcommand\colorchapnum{\color{PineGreen}}
\renewcommand\colorchaptitle{\color{PineGreen}}
\chapterstyle{pedersen} 


% defining the headers, footers, and pagestyle
\pagestyle{headings}

\makepagestyle{headings}
    \makeevenfoot{headings}{{\Large\color{PineGreen}\thepage}}{}{}
    \makeoddfoot{headings}{}{}{{{\Large\color{PineGreen}\thepage}}}
    \makeevenhead{headings}{\footnotesize {\color{PineGreen}\rightmark}}{}{}
    \makeoddhead{headings}{}{}{\footnotesize {\color{PineGreen}\leftmark}}
    \makeheadrule{headings}{\textwidth}{\normalrulethickness}
    \makefootrule{headings}{\textwidth}{\normalrulethickness}{\footruleskip}

\makepagestyle{plain}
    \makeevenfoot{plain}{\thepage}{}{}
    \makeoddfoot{plain}{}{}{\thepage}


\aliaspagestyle{chapter}{empty} %         pagestyle "plain" on first page of chapters
\aliaspagestyle{cleared}{empty} %       pagestyle "empty" on cleared pages (blank pages)



\OnehalfSpacing       % one-half spacing between adjacent lines of text, but not within captions and the like

\flushbottom          % stretch out pages to obtain equal height (default with twoside)
%\raggedbottom        % not stretch out pages

% ToC/ToF/ToT: page number next to entries
\renewcommand{\cftsubsectionleader}{}
\renewcommand{\cftsubsectionafterpnum}{\cftparfillskip}
\renewcommand{\cftsectionleader}{}
\renewcommand{\cftsectionafterpnum}{\cftparfillskip}
\renewcommand{\cftchapterleader}{}
\renewcommand{\cftchapterafterpnum}{\cftparfillskip}

\AtBeginDocument{\addtocontents{toc}{\protect\thispagestyle{empty}}}  % empty pagestyle on toc page

\setsecnumdepth{subsection} % lowest structural level in toc

% setting color in toc
\setsecnumformat{\color{PineGreen}\csname the#1\endcsname\quad}
\setsecnumdepth{subsubsection}

\setsecheadstyle{\color{PineGreen}\Large\bfseries\memRTLraggedright}
\setsubsecheadstyle{\color{PineGreen}\Large\bfseries\memRTLraggedright}


\endinput
1

I guess I answered my own question this time. I tried to not "require biblatex package" in my package document, but instead used "usepcakge" in the actual thesis document. That seemed to solve the problem. Now everything works brilliantrly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.