1

I write my thesis using biblatex for bibliography (JabRef for bibliography database) and need to cite an author, that don't have first name and last name, but has name and toponymical nickname.

I have a following entry in .bib file:

@Book{simeon,
    Title                    = {Vertograd mnogocvetnyj},
    Author                   = {Simeon Polockij,}, 
    Date                     = {1996-2000},
    Location                 = {Koln, Wemar, Wien},
    Publisher                = {Bohlau},
    Year                     = {1996 - 2000},
    Editor                   = {by Anthony Hippisley a. Lydia I.~Sazonova. With a Foreword by Dmitrij S.~Lihačev.},
    Language                 = {english},
    }

In JabRef I see the authorname displayed correctly (Simeon Polockij. Vertograd mnogocvetnyj). But when building bibliography the "," in the end of the name is removed, and the authorname is proceeded in a usual way, and I get "Polockij S. Vertograd mnogocvetnyj", what is totally incorrect.

\documentclass[12pt]{article}
\usepackage{extsizes}
\usepackage{indentfirst}

\usepackage[english,russian]{babel} 

\usepackage{fontspec}     
\defaultfontfeatures{Ligatures={TeX},Renderer=Basic} 
\setmainfont[Ligatures={TeX,Historic}]{Times New Roman} 
\setsansfont{Comic Sans MS}                    
\setmonofont{Courier New}
\usepackage{indentfirst}

\usepackage[backend=biber,style=gost-numeric, bibencoding=utf8,sorting=none,maxcitenames=2,]{biblatex}
\addbibresource{mwe_bib.bib}

\begin{document}
I cite one of the main sources of my research here \cite{simeon}

\printbibliography
\end{document}

How to force biblatex not to abbreviate the second part of author name, to get something like "Simeon Polockij. Vertograd mnogocvetnyj. Ed. by Anthony Hippisley a. Lydia I. Sazonova. With a Foreword by Dmitrij S. Lihačev. Bohlau, 1996 - 2000

  • 1
    The comma immediately after "Polockij" in the author field is almost certainly a mistake and should be removed. Why does JabRef include the title of the book, "Vertograd mnogocvetnyj", in the author field? Can you change that? Have you tried setting the editor field to Anthony Hippisley and Lydia I. Sazonova, i.e., removing "by" and changing "a." to "and"? Finally, is it absolutely necessary to list the author of the Foreword in the bibliography? – Mico Jul 25 '14 at 12:52
  • indentfirst is specified twice in your MWE which is not minimal at all: I guess that the whole part between \usepackage{fontspec} and \usepackage{indentfirst} is useless. + Do you compile your document with XeLaTex? – Clément Jul 25 '14 at 14:04
  • Did you tried to add abbreviate=false as an option to biblatex? – Clément Jul 25 '14 at 14:06
  • Thanks for improving my MWE, I'll try to be more accurate next time :) @Clément, abbreviate=false does a different thing: using "editor" instead of "ed.", "pages" instead of "p." etc. – yukari Jul 25 '14 at 16:30
1

Try the following .bib file:

@Book{simeon,
  Title                    = {Vertograd mnogocvetnyj},
  Author                   = {{Simeon Polockij}},
  Editor                   = {Hippisley, Anthony and Sazonova, Lydia I.},
  Publisher                = {Bohlau},
  Year                     = {1996\,--\,2000},
  Foreword                 = {Lihačev, Dmitrij S.},

  Langid                   = {english},
  Location                 = {Koln, Wemar, Wien}
}

Also add autolang=other to your biblatex options.

0

You should not "overprotect" your author field. You can just add the firstinits=false option to biblatex. Your bib file contains a lot of errors, I corrected some of them. The biggest is probably providing an interval for a date of publication.

% Compile with
% XeLaTex
% Biber
% XeLaTex
\documentclass[12pt]{article}
\usepackage{indentfirst}
\usepackage[english,russian]{babel} 
\usepackage{fontspec} 
\usepackage{csquotes}
\usepackage[backend=biber, style=gost-numeric, bibencoding=utf8, firstinits=false]{biblatex}

\begin{filecontents*}{bib.bib}
@Book{simeon,
Title={Vertograd mnogocvetnyj},
Author={Polockij, Simeon}, 
Date={1996},
Location={Koln, Wemar, Wien},
Publisher={Bohlau},
Year={1996},
Editor={Hippisley, Anthony and Sazonova, Lydia I.},
addendum={With a Foreword by Dmitrij S.~Lihačev},
Language={english},
}
\end{filecontents*}

\addbibresource{bib.bib}

\begin{document}
I cite one of the main sources of my research here \cite{simeon}

\printbibliography
\end{document}

Output

  • Alternatively, you could use the \,--\, to specify a range, as proposed by @invece. – Clément Jul 25 '14 at 17:00
  • If I understand right, \firstinits=false affects all entries, and this is not what I want (such form of author name is needed only for medieval authors with toponymical nicknames, not for modern ones). So it seems to be easier to "overprotect" the Author field in several cases. – yukari Jul 25 '14 at 17:19
  • @yukari It is easier indeed, but I find it a bit inelegant. I must admit I did not pay attention to the subtlety of your question (that it was not a name and a first name, but a nickname). – Clément Jul 26 '14 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.