6

I use the code below to produce handouts of my presentations.

When I open the resulting pdf with any pdf viewer, it is viewed correctly, but when I print it, it is always printed very small, no matter the program I use (Okular, Evince, Acrobat...). Bonus to anyone that can make the pdf be printed correctly by Okular under Ubuntu! Thanks!

MWE here:

\documentclass[handout]{beamer}
\usepackage{pgfpages}
\pgfpagesuselayout{2 on 1}[a4paper,border shrink=5mm]
\setbeameroption{show notes on second screen=bottom}

\setbeamercolor{background canvas}{bg=pink}

\mode<presentation> {
    \usetheme{Singapore}
}
\begin{document}


\begin{frame}[plain]
    \titlepage  
\note{
    Notes for the title page
}
\end{frame}


\section*{Outline}
\begin{frame}[plain]
\frametitle{Outline}
    \tableofcontents

\note{
    Notes for the table of contents
}
\end{frame}

EDIT:

If I place the line "\pgfpagesuselayout{2 on 1}" after the line "\setbeameroption{show notes}" I do not experience the printing problem anymore!! However, the slide preview and notes that appear at the bottom belong to the NEXT SLIDE, instead of to the CURRENT SLIDE!! What is going on with that?

  • Are you sure that the printer settings aren't the problem? – Juri Robl Jul 28 '14 at 20:10
  • It only happens when I generate these kind of beamer handouts, and persists even if I increase "border shrink" to more than the margins in print settings – DaniCee Jul 28 '14 at 20:21
  • It seems to work if you use the Acrobat setting "adjust" (or something like that, I don't have an English version). – Juri Robl Jul 28 '14 at 20:29
  • Yeah Acrobat gives that option, but the software I use in Ubuntu like Okular or Evince does not... and conceptually, I do not really understand why the resulting pdf is bigger than the printing area and needs to be adjusted, when I specify it should be of a4paper or letterpaper size, and even increasing the borders does not make it being printed correctly – DaniCee Jul 28 '14 at 20:58
  • something weird happens @cyberSingularity... when I change the order of the lines "\setbeameroption{show notes}" and \pgfpagesuselayout{2 on 1} I do not experience the printing problem anymore!! However, the slide preview and notes that appear at the bottom belong to the NEXT SLIDE, instead of to the CURRENT SLIDE!! What is going on with that? I have edited the question to reflect that – DaniCee Jul 29 '14 at 0:02
3

This has nothing to do with TeX, just with your printing properties. The document generated by your above MWE has a size of 128 mm \times 192 mm, so it is much smaller then Din A4. If you print it without scaling you will end up with a small image in the centre of the paper:

enter image description here

If you let your printer do its job and either scale it (e.g. 140% seems to be a good start) or fit to paper, you will get the whole page filled:

enter image description here


Or, instead of fiddling around with the printer options, compile the pdf directly to a Din A4 version, i.e. not interfering with the pgf resizing by omitting on second screen:

\documentclass[handout]{beamer}
\usepackage{pgfpages}
\pgfpagesuselayout{2 on 1}[landscape,a4paper,border shrink=5mm]
\setbeameroption{show notes}


\setbeamercolor{background canvas}{bg=pink}

\mode<presentation> {
    \usetheme{Singapore}
}
\begin{document}


\begin{frame}[plain]
    \titlepage  
\note{
    Notes for the title page
}
\end{frame}


\section*{Outline}
\begin{frame}[plain]
\frametitle{Outline}
    \tableofcontents

\note{
    Notes for the table of contents
}
\end{frame}


\section{Frame 1}
\begin{frame}
\frametitle{Frame with notes 1}
    FIRST FRAME CONTENTS

\note{
    Notes for the first frame
}
\end{frame}


\section{Frame 2}
\begin{frame}
\frametitle{Frame with notes 2}
    SECOND FRAME CONTENTS
\note{
    Notes for the second frame
}
\end{frame}


\section{Frame 3}
\begin{frame}
    \frametitle{Frame with notes 3}
    SECOND FRAME CONTENTS
    \note{
        Notes for the third frame
    }
\end{frame}


\end{document}
  • Then the question is: Why does the document generated by the MWE have a size of 128 mm x 192 mm when I clearly specify a4paper with 5mm of border?? – DaniCee Jan 29 '17 at 12:21
  • @DaniCee See my edit, the on second screen does not play nicely with the resizing. – user36296 Jan 29 '17 at 12:34
  • Alright!! "show notes" instead of "show notes on second screen=bottom" does the trick! But why? – DaniCee Jan 29 '17 at 12:37
  • @DaniCee My guess, because the show notes on second screen changes the paper size after the pgf layout was already resized the paper? (just a guess, did not look in the code) – user36296 Jan 29 '17 at 12:39
  • Woah so much into this thing and the solution was so simple... Thanks! – DaniCee Jan 29 '17 at 12:41
2

The following solution is really ugly and I hope someone finds a nicer one. I set the papersize explicitly to A4 (the height is half of it, because it consists of two slides):

\documentclass[handout, xcolor={dvipsnames,table}]{beamer}
\usepackage{pgfpages}

% A4 Paper Size and some small additional margin
\paperheight=143.5mm %297mm / 2 - 5mm
\paperwidth=205mm % 210mm -5mm

% border shrink and a4paper doesn't seem to work like I wanted it to..
\pgfpagesuselayout{resize to}[a4paper,border shrink=5mm] % could also use letterpaper
\setbeameroption{show notes on second screen=bottom} % Beamer manual, section 19.3
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\setbeamercolor{background canvas}{bg=pink}

\setbeamertemplate{note page}[plain] % Beamer manual, section 19.1
\newlength{\parskipbackup}
\setlength{\parskipbackup}{\parskip}
\newlength{\parindentbackup}
\setlength{\parindentbackup}{\parindent}
\newcommand{\baselinestretchbackup}{\baselinestretch}

\usetemplatenote{

  \insertslideintonotes{0.3}%

  \rmfamily \scriptsize%
  \setlength{\parindent}{1em} \setlength{\parskip}{1ex}%
  \renewcommand{\baselinestretch}{1}%

  \insertnote%

  \setlength{\parskip}{\parskipbackup}%
  \setlength{\parindent}{\parindentbackup}%
  \renewcommand{\baselinestretch}{\baselinestretchbackup}%
}
\begin{document}

\begin{frame}
Title slide
\note{this is a note}
\end{frame}

\begin{frame}
This is the first slide
\note{this is another note}
\end{frame}

\end{document}

To change the borders just shrink the papersizes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.