2

I am running an Arch Linux / Windows 7 dual boot laptop.

The windows partition is mounted under arch and i made the windows fonts usable with ln -s /windows/Windows/fonts/ /usr/share/fonts/WindowsFonts

This works, every program besides luaLaTeX with fontspec has acces to the fonts, e.g. libreoffice.

But i am not able to use the fonts with:

\usepackage{fontspec}
\setmaintfont{Comic Sans MS}

The result is the font-not-found message from fontspec. Under the Windows 7 partition it works just fine.

Any idea?

3

I found the solution: Lua uses a font name data base, which I had to update using the command:

luaotfload-tool --update
  • 1
    What version of Luaotfload do you run? You can find out running luaotfload-tool --version. The current version (2.5) should update the font index automatically if a font couldn’t be found, unless you explicitly disabled the updates in the configuration file. In any case it should work on Arch because that’s the platform it is being developed on. If not then you most likely found a bug. – Philipp Gesang Jul 26 '14 at 16:28
  • I keep my packages up to date, so it's the version currently delivered by the texlive packages. Version is 2.4.-3 – MaxNoe Jul 26 '14 at 16:39
  • 3
    That’s an old one and it had the bug you describe. Unfortunately, the TeX packages in most distros are crap and Arch is no exception. You could install a current TeX live yourself, otherwise you will have to wait for the Arch maintainers to catch up. – Philipp Gesang Jul 26 '14 at 16:53
  • Probably the Best solution – MaxNoe Jul 26 '14 at 17:58
  • 1
    i installed texlive 2014 from tug and the AUR texlive-dummy package now and everything seems to work fine – MaxNoe Jul 27 '14 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.