0

I need upright math operators such as \sin, \tan etc., italic uppercase greek letters and a working \partial operator. With the code below I was able to get two out of three, but I was told that it's not the recommended way of achieving what I need (see comments). And I still need a \partial sign.

\documentclass[convert]{standalone}

\usepackage[math-style=ISO]{unicode-math}
\usepackage{amsmath}

\usepackage{fontspec}
\setmainfont[Ligatures=TeX]{TeX Gyre Pagella}
\setsansfont[Ligatures=TeX,Scale=.9]{TeX Gyre Heros}
\setmonofont[Scale=MatchLowercase]{TeX Gyre Cursor}
\setmathfont[Ligatures=TeX]{TeX Gyre Pagella Math}
\setmathfont[range=\mathup]  {TeX Gyre Pagella}
\setmathfont[range=\mathbfup]{TeX Gyre Pagella Bold}
\setmathfont[range=\mathbfit]{TeX Gyre Pagella Bold Italic}
\setmathfont[range=\mathit]  {TeX Gyre Pagella Italic}

\begin{document}

$x\partial x$

\end{document}

How can I get all three things working?

  • 1
    Why do you need those ranges? Aren't they provided by default with TeX Gyre Pagella Math? I mean, those are useful if you want to change the fonts, and you clearly don't. – Manuel Jul 27 '14 at 21:10
  • I had a problem which I was able to solve that way, but I don't remember what it exactly was. I check my document without, maybe I don't need them anymore. – Chris Jul 27 '14 at 21:16
  • @Manuel: I found the problem again. Without these lines, \sin, \tan etc. are printed in italic, and I found this solution on tex.sx. So, do you know why this does not work? Otherwise I have to ask a new question. Thanks anyway! – Chris Jul 27 '14 at 21:22
  • 3
    @Chris: Wherever you found this solution, I’m certain it is wrong, and the missing partial is not the only issue you will face with this “fix”. – Khaled Hosny Jul 27 '14 at 21:34
  • 1
    amsmath should be loaded before unicode-math; see the manual just after “Getting started”. – egreg Jul 27 '14 at 22:05
2

Eventually I was able to find the reason with the great help of the comments to my question. For those observing similar problems, I post an answer here.

  1. The missing \partial comes from reassigning unicode ranges to different fonts. Don't do it unless you know what the side effects are. I didn't and therefore another problem was hidden by this wrong solution.
  2. The option math-style=ISO did not break my math operators. Loading amsmath after unicode-math was the problem (It's stated in the unicode-math manual that amsmath must be loaded before but I was searching for the error somewhere else, thinking that the italic operators were intentionaly set by unicode-math).

So, loading amsmath before unicode-math and removing the range reassignments in the question's code solves everything.

\usepackage[no-math]{fontspec}
\setmainfont[Ligatures={TeX,Common}]{TeX Gyre Pagella}

\usepackage{amsmath}

\usepackage[math-style=ISO]{unicode-math}
\setmathfont{TeX Gyre Pagella Math}
  • I've taken the liberty of adding the correct code. – Mico Jul 27 '14 at 23:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.