3

I am facing a very weird problem; see the output: Output

I am trying to get my table in the landscape mode within a two-column layout. Therefor the package "multicol" is used. The table does not appear on the whole page but ratheronly the top (or left, depending on the perspective). Whenever I remove the multicol package, the table does fill the whole page; but unfortunately the layout of the rest of the paper is destroyed. Is there any workaround? Thanks in advance. :)

\documentclass[twoside]{article}

\linespread{1.08} 
\usepackage[hmarginratio=1:1,top=32mm,columnsep=20pt]{geometry}
\usepackage{multicol}
\usepackage{lscape,multirow,rotating,caption,tabularx,booktabs}
[...]
\begin{document}
[...]
\begin{landscape}
\begin{table*}[b]
\small
\label{tab:2}
\caption{bla}
\bgroup
\def\arraystretch{1.5}
\begin{tabularx}{\linewidth}{lXXXX}
\hline & Grow Bed & DWC & NFT & Soil \\ \hline
[...]
Nutrient uptake  
&- High &- High& - Lower because smaller root-water contact area& - Lower
\\ \hline
\end{tabularx}
}
\end{table*} 
\end{landscape}

\end{document}
  • 2
    Welcome to TeX.SX! It will be easier for others to help if you strip your example down to the bare necessities required to illustrate the problem. Why not just use the class option twocolumn instead of the multicol package? – Paul Gessler Jul 30 '14 at 21:36
  • Your code does not demonstrate the problem you describe. When I compile your code, I get a table in landscape taking the whole page. – cfr Jul 30 '14 at 21:50
4

The landscape mode is not possible inside the multicols environment. Use \rotatebox instead:

\documentclass[twoside]{article}

\linespread{1.08} 
\usepackage[hmarginratio=1:1,top=32mm,columnsep=20pt]{geometry}
\usepackage{multicol}
\usepackage{lscape,multirow,rotating,caption,tabularx,booktabs}
\usepackage{blindtext}
\begin{document}

\begin{multicols}{2}
\rotatebox{90}{%
\small
\minipage{0.9\textheight}
\captionof{table}{bla}\label{tab:2}
\def\arraystretch{1.5}
\begin{tabularx}{\linewidth}{lXXXX}\hline 
& Grow Bed & DWC & NFT & Soil \\ \hline
Nutrient uptake  
&- High &- High& - Lower because smaller root-water contact area& - Lower\\ \hline
Nutrient uptake  
&- High &- High& - Lower because smaller root-water contact area& - Lower\\ \hline
Nutrient uptake  
&- High &- High& - Lower because smaller root-water contact area& - Lower\\ \hline
\end{tabularx}
\endminipage}

\blindtext
\end{multicols}

\blindtext
\end{document}

enter image description here

  • +1: Sorry, is there e^x function in PSTricks? Euler^x seems to be unusual. (It will be deleted shortly) – kiss my armpit Jul 31 '14 at 9:58
  • Thanks a lot. Found another workaround: \end{multicols} before inserting the table and \begin{multicols}{2} right after. :) – Simoneke Goddelijk Jul 31 '14 at 11:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.