3

I'm having a very bizarre problem with ST2 for Mac OSX. I just installed it today, along with the LaTeXTools plugin. With the standard classes it works just fine.

My dissertation, however, uses a custom class (umthesis, which I renamed to umassthesis.cls [and updated the \ProvidesClass accordingly] to avoid conflict with the University of Michigan class on CTAN) and for some reason my ST2+LaTeXTools isn't locating the file. It's giving me the following error in the console: "./umthsmpl.tex:91: LaTeX Error: File `umassthesis.cls' not found. [^^M]"

It is, I believe, in the appropriate place (/Users/Dennis/Library/texmf/tex/latex/umassthesis.cls) and the other program I use to edit TeX (LaTeXian) is finding the class file without issue.

Is there something I need to modify in order to get this working with ST2?

UPDATE:

I also ran latexmk (the same process ST2 runs) from the command line, which also gave me a successful compilation.

UPDATE 2:

Following a comment, I placed the class file in the same directory as the .tex file I'm trying to compile, and it worked. So it seems that Sublime is setting the PATH incorrectly. How do I modify the path ST2 w/ LaTeXTools sets so that it scans my user texmf directory?

  • That's very strange… just to clarify things, is it successful when you compile from the command line? – Sean Allred Jul 31 '14 at 3:39
  • @SeanAllred I just verified that running latexmk (the same process ST2 runs) from the command line yields a successful compilation. – Dennis Jul 31 '14 at 3:57
  • I'm not familiar with Sublime (I use emacs, myself), but do you know if there is any way to configure it to echo the current working directory and the commands it runs as it executes them? – Sean Allred Jul 31 '14 at 4:00
  • @SeanAllred I'm not sure. I would think so, but since I've just started toying with it today I haven't the slightest idea how. I'll dig around docs to try to figure that out. Hopefully a more experienced ST2 user stumbles on this. – Dennis Jul 31 '14 at 4:02
  • @SeanAllred I found this, but it doesn't shed any light on the problem for me: ['latexmk', '-cd', '-e', "$pdflatex = 'pdflatex -interaction=nonstopmode -synctex=1 %S %O'", '-f', '-pdf', u'umthsmpl.tex']. That tell you anything? – Dennis Jul 31 '14 at 4:04
2

Well I found the solution to the problem here. Quoting from the post there:

Alright, I solved it. Something about upgrading to OSX Mavericks changed the path in which the MacTeX TeXLive distribution was located. ...I had to go into LaTeXTools.sublime-settings and change the OSX path. The default setting for OSX is:

"texpath" : "$PATH:/usr/texbin:/usr/local/bin:/opt/local/bin"

You just have to add the following path (/usr/local/texlive) to get things to work:

"texpath" : "$PATH:/usr/texbin:/usr/local/texlive:/usr/local/bin:/opt/local/bin"

2

now the answer is

"path": "$PATH:/usr/local/texlive/2015/bin/x86_64-darwin"
  • 1
    No, on a current MacTeX installation you should use /Library/TeX/texbin. – Alan Munn Sep 16 '15 at 16:42
  • Thank you Professor Munn. But how do I make the sublimetext plugin LaTexTools compile xelatex->bibtex->xelatex ? – בנימן הגלילי Sep 16 '15 at 16:49
  • The answer for texlive2018 is "texpath" : "$PATH:/Library/TeX/texbin:/usr/texbin:/usr/local/texlive/2018/bin/x86_64-darwin:/usr/local/bin:/opt/local/bin" – evaristegd Apr 13 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.